Toad World® Forums

Could not resolve service name on SQL Navigator 6.2


#1

Good day, I have a problem connecting to Database with SQL Navigator 6.2, I’m using Oracle10g Express Edition, on Windows 7 Ultimate 64 bits, everytime I try to connect to the db I get the errror:

**ORA-12154: TNS:could not resolve service name

Make sure connection parameters are correct and try again**

I thought it was a problem related to the tnsnames.ora file, but when I try to login using the web admin page, the one that comes with the database installation, I have no problems, I even installed SQL navigator on a virtual machine with Windows XP 32 bits, and no problems at all, I downloaded SQL developer and tried to connect there and it’s working fine…I don’t know what to do, but it’s not working, and I can login using other methods, as I said, any help would be appreciated, thanks in advanced!


#2

Did you try to connect using the sqlplus utility?


#3

Hi,

There are some issues with some of Oracle clients and having SQL Navigator installed into c:\program files (x86) directory on 64 bit OS. I would like to suggest to unistall your SQL Nav 6.2 then reinstall again into a folder outside program files…,ie. could you please install SQL Navigator into c:\Quest Software\SQL Navigator…

Please also note that SQL Navigator can ONLY support Oracle 32 bits client.

Please let us know how you go.

Thanks,
Bruce


#4

Well, SQL Plus utility does not come with Express Edition ( as far as I know), I will check it, but as I said, I’m able to connect with web admin site, with SQL Developer, and on a 32 bits virtual machine environment, I even use the database with no problems on my JSP application.

I did not know that SQL Navigator had some problem working on 64 bits OS, I will reinstall it and try again as well, I hope that’s the solution, I will let you both know later since I’m at work right now, thank you.


#5

It worked!!! I installed it on C:/ and now I’m able to connect to Oracle, thanks for the help!!


#6

Great to hear that. Thanks for letting us know.

Latest oracle client release v11g should fix this issue where you can install 32 bit application into c:\program files. I have 11g R2 client and having SQL Navigator installed in c:\program files and everything works fine.

Regards,
Bruce