Toad World® Forums

Creating Sequences in Oracle


#1

(BETA 3.4.10.2)

Hi

I’m creating indexes on the fly while working on my model, but everytime I have to go to the details of each sequence just to clear the CACHE setting to NO CACHE.

Is there maybe already a setting where I can change this default to NO CACHE?

If not, something like that would be very nice regarding productivity when creating the models.

Best Regards
Rudi


#2

Hi Rudi,

Please use the attached script. Run it in Scripting Window (Tools menu, Expert mode must be on: Settings | Options | General | Expert Mode checkbox.).

The script will set all sequences to NOCACHE in your model.

Unfortunately, this is the only solution we can offer you at this moment. Thanks.

If you have any questions, please write us back.

Regards,

Vladka + Mario
SetSequenceToNOCACHE.js (562 Bytes)


#3

Hi Rudi,

Is there maybe already a setting where I can change this default to NO CACHE?

Another suggestion - please use the Expert mode and define a default value of property “NoCache” for sequences.

  1. Enable Expert Mode (Settings | Options | General).
  2. Edit a sequence.
  3. Right-click the dialog of the sequence and select Default Values for Class.
  4. In the first column Name, find the NoCache property and set its Default Value to True.
  5. Confirm.

Movie on this issue:
http://modeling.inside.quest.com/entry.jspa?externalID=1696&categoryID=281

Sorry for the delay, I simply forgot we have such a great feature! :slight_smile:

Regards,

Vladka


#4

Brilliant, exactly what I was after. I see it works for most of the Classes as well, like Entities and Attributes. I really have to say, this product amazes me everyday still.

Have a great day and thanks again for all the help.

Regards
Rudi