Toad World® Forums

Ctrl/e not working for Explain Plan in Editor


#1

ctrl/e does nothing in Editor. beta .10


F9 and Ctrl-E not working
#2

I just tried a simple SELECT in .10 (32 and 64-bit) and it is working here. Is it all statements for you or something in particular?


#3

I started a new instance of Toad with 1 editor window. Ctrl/e worked the 1st time and then stopped working. Closing and reopening Editor window and disconnecting session and reconnecting with new Editor window did not solve this.
F9 and F5 weren’t working either.
Closed that instance of Toad and started a new one. Everything is working fine now.
I have another instance of Toad up from days ago that is experiencing this issue - ctrl/e, f5, f9 do nothing. Other f-keys seems to work just fine.
I’ll see if I can determine a pattern, as time permits.


#4

I have reproduced an issue with F9 ceasing to work.
I open Toad, open Editor window, connect to db, type in SELECT * FROM DUAL;
Hit F9 repeatedly in quick succession, or just hold down the key, and it will eventually stop working. Same happens for shift-F9.
The number of repeats before it stops working seems to vary, or maybe it depends on the speed of the repeats. Holding down the key, it happens quickly.
Obviously this is not something I would normally do, but F9 stopped working again early today so I wanted to try and reproduce ASAP. I assume there’s some other trigger that causes this issue, but I’m hoping that since this scenario is reproducible, it might lead to some root cause that may be related to F5 and ctrl/e issues (neither of which I can’t reproduce).


#5

Hey Dale,

We were able to find and fix the cause of the issue, but we weren’t quite in time for today’s beta. It will be in Thursday’s beta, however. In the meantime, you may need to either close your connection and reconnect, or exit and restart Toad if this happens to you again before Thursday’s beta.

-John


#6

Thanks, John. It happens quite a lot, so when the shortcuts stop working, I just use the buttons. Less convenient, but usually easier than closing everything and restarting Toad. I think I tried reconnecting without restarting Toad and that didn’t help.


#7

Yay! Thank you so much for fixing this. :slight_smile: So glad I’ll be able to use my keyboard for these things again.