Toad World® Forums

Shortcuts not working...

In the latest beta .55, the default keyboard shortcut (Shift+F9) for Execute Snippet is not working. When I try it, nothing happens. It was working in the prior beta.

I forgot to mention that I did try the “Reset current” and “Reset all” buttons, but neither resolved this.

How about CTRL+Enter, does that work? Look in Options under the Toolbars/Menus|Shortcuts page. Is the Shortcut for Editor->Execute Snippet set to Shift+F9?
If so, please send a code snippet and indicate your caret location within. I’ve tried with a simple select and a select within an anonymous block without any problems.

Thanks,

Michael

From: msacks_703 [mailto:bounce-msacks_703@beta.toadworld.com]

Sent: Wednesday, May 22, 2013 1:10 PM

To: toadoraclebeta@beta.toadworld.com

Subject: [Toad for Oracle - Beta Discussion Forum] Shortcuts not working…

In the latest beta .55, the default keyboard shortcut (Shift+F9) for Execute Snippet is not working. When I try it, nothing happens. It was working in the prior
beta.

Hi Michael,

I tried CTRL+Enter, and that works. I’m attaching a screen shot showing that Execute Snippet is set to Shift+F9. I’m going to try a reboot to see if that solves the issue.

–Mitch
ExecuteSnippet.jpeg

I think I found the issue. I installed the latest version of SnagIt today, and it apparently hijacked Shift-F9 for its purposes. Once I disabled it in SnagIt, Toad worked as expected. Sorry for the fire drill. :slight_smile:

Thanks this helped solve my problem as well. :slight_smile: