Toad World® Forums

Ctrl-T does not bring up seelction list


#1

All,

from time to time, when I hit Ctrl-T to bring up a selection list, nothing happens.

I.e. I can see Toad is busy for a short while, then: nothing.

Unfortunately, I have no clue what causes this to happen.

I tried typing sys. then Ctrl-T - same thing.

It must be something with my session. I just opened a second instance of Toad, connected to the same database/schema then typed sys. and hit Ctrl-T. No problem at all - I do get the list of defined objects in the usual drop-down.

Oh - I’m on Beta 76 right now.

Kind regards,
Abe Kornelis.


#2

Re-post… first email didn’t make it,

In both of your scenarios did you have the same text in the the editors? Was “sys.” the only text? If there are syntax errors upstream of your text then Code Insight will be affected if the parser can’t overcome them.

Michael


#3

Michael,

It’s good to know syntax errors may affect the usability of the object pop-up.

Anyway, the editor window was holding a package that I needed to debug.

The change I was making was the only change. Without the change, the package compiled ok.

As part of the test, I also tried in a separate window holdin nothing but sys.

Abe

===