Toad World® Forums

Data Grids in 10.6

I’ve just upgraded to Toad 10.6 and noticed that when running a query from the editor, the data grid doesn’t automatically pop-up and display the results when the query has finished. This used to happen in 10.5.

Is there any way of turning this on in 10.6 as it served two useful purposes:

  • The grid popping up identified that the query had completed
  • It was possible to immediately view the results without having to use a mouse click to open the data grid.

I should say that my tabs are usually not fixed in an open position i.e. they scroll up and down as I navigate over them.

Message was edited by: paul.hill_593

Did you try the Ctrl-F2 button? That one places the divider in the middle of
the two windows.

Groetjes,
Wim

On Mon, Dec 13, 2010 at 13:45, paul.hill_593
wrote:

Message from: paul.hill_593

I’ve just upgraded to Toad 10.6 and noticed that when running a query
from the editor, the data grid doesn’t automatically pop-up and display
the results when the query as finished. This used to happen in 10.5. Is
there any way of turning this on in 10.6 as it served two useful purposes: -
The grid popping up identified that the query had completed - It was
possible to immediately view the results without having to use a mouse click
to open the data grid. I should say that my tabs are usually not fixed in an
open position i.e. they scroll up and down as I navigate over them.

_______________________________________

Historical Messages

Author: paul.hill_593
Date: Mon Dec 13 04:45:11 PST 2010
I’ve just upgraded to Toad 10.6 and noticed that when running a query
from the editor, the data grid doesn’t automatically pop-up and display
the results when the query as finished. This used to happen in 10.5. Is
there any way of turning this on in 10.6 as it served two useful purposes: -
The grid popping up identified that the query had completed - It was
possible to immediately view the results without having to use a mouse click
to open the data grid. I should say that my tabs are usually not fixed in an
open position i.e. they scroll up and down as I navigate over them.
__
_______________________________________

Hi, Ctrl-F2 doesn’t seem to do anything in my copy of Toad. If the purpose of this key combination is to simply display the data grid then it still doesn’t resolve my problem.

In Toad 10.5 the data grid would pop-up and display the results automatically when the query finished.

In Toad 10.6 this doesn’t happen and it is necessary to use the mouse to hover over the data grid tab, which will then pop-up the grid.

I would like the 10.5 functionality to be enabled in 10.6 if possible or has this feature been removed?

I had exactly the same problem. I am using 10.6. But the problem didn’t occur right after the upgrade. It worked for a while. Then it stopped working recently. I had to hover the mouse on the “Data Grid” icon to have the popup grid showing up. It still auto-hides after move the mouse currsor away from the grid.

I also have some colleagues have the same problem. But others (using 10.6) have this popup grid functioning just fine.

I have the data grid, query viewer, etc. window pinned, and noticed this in a different way. Before 10.6 if I was on a different tab, say the query viewer, when the running query completed the data tab would automatically select and come to the front. Now I have to note that the query has completed and click on the data tab. I assume if I didn’t have the window pinned I’d have to hover or select it as well.

Not a big deal I guess, but was curious about the change as well.

I went back to Toad 9.7 and see the same behavior as I’m seeing in 10.6.
If I start a query and then go to the query viewer, the data grid does not come
back to the front when the query finishes. Am I missing something? I’ve
checked options and don’t see anything that would affect this.

I am also having the same issue. I’m currently using 10.6.1 in a Win7 x64 environment as are 3 other of my colleagues. 2 of us are having the issue and the other 2 are not having any issues. Same version and environment. One day it’s working and the next day it’s not. Did a clean install of 10.6.1 and that didn’t fix the issue.

Does anyone at Quest have any idea what’s going on with this? Seems that there are a couple of folks affected by this.

From the developer:

Here is the logic for determining which dock panel is activated.

When execution completes…

If Query Viewer panel is active, do nothing, leave it as active

Otherwise…

If AutoTrace is enabled…

If SQL executed is not a SELECT, activate Auto Trace panel

Otherwise, if SQL is a SELECT, activate Data Grid panel if and only if Auto
Trace panel is not active

Otherwise, if AutoTrace is not enabled

If SQL executed is a SELECT, activate the Data Grid panel

hi to all
to solve this issue
first
right click on the Data Grid Bar
then
Desktop Panels
after that
configure Desktop Layouts
finally
set the dock site for data grid to button

tnx all

Hi Mohammed,
When I right click on the Data Grid Bar, I see Configure Desktop Layouts right away (I don’t see Desktop Panels). When looking at the dock site for data grid, I don’t see ‘button’ only ‘bottom’ which I assume is what you’re telling us to set it to. Mine was already set to that. I set it to left and then back again to bottom and it did not fix the issue.

Quest…time to step in with a solution?

Mark

All,
Not sure if the issue I was having is the same or not, but mine was fixed by doing the following: - Right click in the Data Grid Bar (or toolbar on bottom of the screen)- From there select "Restore Default Desktop"After doing this, I was able to see both my query and results in the data grid below.
I hope this helps! Good luck! J

Unfortunately that is not the issue we’re seeing. We’re able to see both the query and the data grid if we want to by hitting ‘F2’. The problem is that before upgrading to 10.6 the data grid would pop up automatically for 3 seconds or so whenever you ran a query as a ‘quick preview’. After the upgrade, you need to hit ‘F2’ to get it to show and then ‘F2’ again for it to go away. Very annoying issue. Also annoying is that downgrading to 10.5 doesn’t fix this. Once it’s broke, it’s broke. I hope that I summed up everyone’s issue very well.

I just upgraded to v11 and the issue was fixed for me. Now when I execute a sql query the data grid automatically pops up for a few seconds and then goes back down.

Doesn’t look like this is getting any attention for a fix in 10.6 and now that it works in v11, it looks even more unlikely that it will get patched in 10.6. Solution: upgrade to v11!

Here is the trick to do it:

  1. Close all instances of Toad and reopen a single new instance.

  2. Write a simple query and click F9 to execute it. (the results will show and then disappear/scrolldown)

  3. Click on “Data Grid” on bottom left to make the data grid visible.

  4. Click Shift + F2 once

  5. Right click the bottom bar of the Toad screen, and select “Lock Toolbars”

  6. Hover mouse pointer towards the top edge of the data grid and when it changes to border move control (two parallel lines with down and up arrow), click the left mouse button and drag the top edge of the data grid down (where you want it).

  7. close Toad

  8. Reopen Toad and retry a query, it will show both the query and the data grid simultaneously as you used to love seeing it.

Hope it helps!!!

Click on the “pin” icon on the right-hand side of the data grid bar next to the ‘X’ close icon. This toggles auto-hide/lock for the data grid.