Toad World® Forums

Data Point 3.8 numeric values retrieved from OBIEE have no decimals

I’ve recently started using Data Point (ver. 3.8) to pull data from an Oracle Business Intelligence server into Excel spreadsheets. I use a very simple query and it works properly, with one exception: numeric data is rounded (or maybe truncated) to zero decimal places. When I run an identical query through the Oracle BI web interface, I get the decimal places; so, I know something is definitely wrong on the Toad side.

I’ve found a few forum threads from a few years ago stating a CR was submitted for this problem. Am I missing something, or is this still not resolved?

Thanks for any help you can provide.

Hello Mitch.Lear,

Thanks for your comment.

May I ask you if the values in the Excel table are really rounded, or there's only cell format set to display the values as rounded? Could you also try exporting the data for example into Comma Separated Values? Are the numeric values correct there?

I'd also suggest you to try defining some custom format on columns with numerical data:

Libor

The numbers are truly decimal-truncated (or -rounded) no matter the export format (.csv, .html, .xlsx). The data type for the field is REAL and I set the format to Fixed-Point. No luck there, either.

Thank you for the information provided.

We will try to reproduce the problem at our side and let you know about our findings.

In the meantime you might want to try the latest TDP Beta version and see if it fixes the problem.

Hello Mitch.Lear,

Then it looks like a bug. We’ll try to reproduce the problem.

Could you test it in the latest beta (TDP 4.0)?

https://www.toadworld.com/products/toad-data-point/toad_data_point_beta_program/

Thanks.

Libor

I’m checking into this now.

I have confirmed this is still an issue and entered QAT-8104 to fix. Unfortunately this will not make it into the TDP 4.0 release.

Thank you for looking into this, Debbie. I was afraid that was the case.

Mitch Lear
Dell Software Group

Hi,

Did you try to push data in a pre formatted excel ? (“append rows” option of export).

I use to do that every time.

I don’t know Oracle BI but i’m working every day on oracle servers…