Toad World® Forums

data results different with joins and/or suqueries

The community was very helpful to me to get a query built for Toad Datapoint with a Vertica database. I can get the query to run, but the output data/results is different for the same data that inputted to the older Toad for Oracle database. I have been trying to find out why and have not made progress.

The present sql has 2 subqueries and each subquery has 3 inner joins. I need data from 6 different tables. If 1 run just one of the subqueries stand alone, it is the same data as when I run ther complete sql. If I run just the data for any of the individual tables by itself, the data matches 100% to the Toad for Oracle. To me it is not a subquery issue, but more of a inner join issue.

The other part is trying to get a formula to obtain a Success Ratio.

THANKS in advance

after a few days of looking at all this, I see the “join” query results are 400 times the stand alone query, if that helps

Hi mf1375,

Toad doesn’t modify the query. It only passes the query to database provider (vertica/oracle). It is possible that vertica processes joins differently than oracle. Can you send your query?

Petr