Toad World® Forums

Data Service Database Error - How to get more information?


#1

I have a script that runs fine from TDP 4.3 on my machine. When I publish it to Intelligence Central it fails with “Data Service Database Error” and no other information is provided. Is there a way to get more information about the error?

Thanks,

Tom


#2

Hello,

Does it happens consistently?

It looks like it is the toad try to connect to server but failed.

1> Does your side and TIC server side both could connect to the DB you use?

2> You could check in path like:

TIC service log file: C:\ProgramData\Quest Software\Toad Intelligence Central\logs

Toad.log: C:\Users\Administrator\AppData\Roaming\Quest Software\Toad Data Point 5.0

3> If you could not find out why, you could create a support case.

Regards

Lyla Su


#3

Thanks Lyla,

There is not a logs directory in the path on the TIC. It seems that as the system is inserting data into the target table on TIC it randomly fails and reports a data service error. The script will fail on different records in the file. So for example, the scheduled job died on record 866 overnight. I ran the script this morning on the server to test it and it loaded up to record 897. So it randomly fails, and it has been loading fine for the last four days. Very strange.


#4

I assume you are talking about a TDP automation script that is published and scheduled on TIC server.

When you said you ran the script on the server did you start up TDP remotely and run the automation script from within TDP? We need to get more logging turned on. Can you add /log=all to short cut of TDP on TIC server and run the script from within TDP? If you can reproduce the error generate a support bundle and attach to this post.

I’ll find out if we can turn on more logging when run by TIC.


#5

Overnight the script ran fine. This morning I followed your instructions and updated the shortcut for TDP on TIC and tried running the script. It failed but loaded the first 1,033 records of about 25K. I looked in both locations (TIC & TDP) for log files but did not see a logs directory. I can attach a support bundle, do we want to get the logging working first?


#6

if you ran TDP manually with the command line you you generate support bundle and attach. i did find out how to turn on logging when TIC is running TDP Automation. But this is extra layer and if you can produce manually this would be better.

One of the files I am looking for is toad.log file which is located in Toad’s App Data Dir (link to this dir is on About screen)


#7

I generated a support bundle that includes the log. I tried attaching it to this post but the system keeps throwing an error asking me to attach a file. My email address is tmslayton@theconnectioninc.org if you send me an email I will reply with the support bundle.

Best,

Tom


#8

So, I went through the query that is being executed and pushed as a DataSet to TIC. There are two DateTime columns at the end of the query. If either of those columns are included in the push to TIC fails. If I comment them out the job works perfectly. I tested this by scheduling the job to run once a minute and was able reproduce the error. I don’t understand why it is failing though because I have four other DateTime columns in the query that load perfectly.

I profiled the data that is in the two failing columns and there is nothing out of the ordinary in them. Just NULL and DateTime values.


#9

Okay, we are getting somewhere. Our error handling this not very helpful but it seems it is data driven.

Please send the support bundle you generated to debbie.peabody@[mention:def66d60eb544ed49068355523d182dd:e9ed411860ed4f2ba0265705b8793d05]

Also, can you execute the quey in the SQL Edtior and save as a *.tef file (Toad Edtioer file). This will save the data for me so i can reproduce.

One last thing, when you have the sql in the editor can you generate a second support bundle? You don’t have to send me both. But I am looking for the SQL Anlayze.log file in the App Data Dir. (Access to dir is from help | About window

With the a complete zip file support bundle, the TEF and SQLAnalyze.log file i should be able to figure out what happened.


#10

Did you send any data? I have not received.


#11

Hi Debbie,

The Connection is a HIPAA covered entity and the data is sensitive. Before I can send the data I need Quest to sign a BAA. How can we facilitate that?

Tom


#12

You will need to open a support ticket and they will handle the BAA