Toad World® Forums

DBMS Output Toad Data Point vs Toad for Oracle

below is an example of what I mean regarding the difference in the way that TOAD Data Point seems to handle DBMS Output compared with TOAD for Oracle.

First some context: we use PL/SQL a fair bit for our more complex data requests. As these requests are generally ad hoc, the code is executed by us in TOAD as anonymous blocks and we retrieve the results via DBMS Output.

This is a simple code example (we would not normally use PL/SQL for this case) using TOAD for Oracle:

The DBMS Output tab in TOAD for Oracle lets you save the result to a text file with output as follows:

5336

6100

6618

5647

5776

9911

In TOAD Data Point we can execute the same script, however there is no specific DBMS Output tab, instead you have to retrieve the output via the Messages tab (in this case I have already selected to filter the messages by DBMS Output so that all other items are removed from messages):

Unfortunately the Timestamp column remains in the output, even if I right-click on the column first to remove it from messages.

Saving the result as a text file always seems to include the timestamp portion as a prefix to each row:

11/11/2014 10:10:16 AM: 5336

11/11/2014 10:10:16 AM: 6100

11/11/2014 10:10:16 AM: 6618

11/11/2014 10:10:16 AM: 5647

11/11/2014 10:10:16 AM: 5776

11/11/2014 10:10:16 AM: 9911

Is there any way to prevent this from happening, or is there an alternative approach to obtaining DBMS Output for us to consider? Ideally it would be nice to be able to send the output directly to an Excel workbook or to a table in an MS Access database.

I also seemed to have trouble getting the Compare functionality to work. I was trying to compare two tables with the same structure (i.e. field definitions) from an MS Access database with only minor data differences in one or two rows, however the comparison results always seemed to highlight all the rows as being different. Perhaps I am not using the function correctly. Do you have any online tutorials for this that you could point me to?

I tried to get rid of the date and couldn’t.

I created QAT-4305 to look into this issue

Sorry to hijack this thread, but this is one of the few I found that deals partially with issue I’m having.

I’m using Toad Data Point 4.0.1.775 to run a simple Oracle Stored Procedure that produces DBMS output. However, I can’t figure out where to see the DBMS output. If I’m understanding the original question in this post, the poster was able to see the output in the Messages tab, but I don’t. Can someone help me figure out where/how to see the DBMS output?

When I run the same procedure in Toad for Oracle this is what I get:

dbms_output_in_ToF.jpeg

Go to the message tab. There is a sticky button that you need to press to request the DBMS_Output to be displayed