Toad World® Forums

DDL Script generation TDM 5.5

Hi,

We have just installed TDM 5.5.3.20. (On windows 7 64 bit). We are using Oracle 11R2

When I try to generate DDL for my model I get “List index out of bounds (-1)”.

The model generated OK in TDM 5.3.

We get the same error on an updated pc or on a new install.

I have tried RE from the script generated in 5.3 but get the same error.

Any ideas on how to fix it would be appreciated.

Hi Malcolm,

Let’s address the two errors separately:

DDL Script Generation error

  • Please look for a log (.elf file) in the following folder and send it to us - __C:\Users*user\AppData\Roaming\Dell\Toad Data Modeler__

  • Another way is to check the Copy to Clipboard option when the error appears again and send us the information in a plaintext file.

  • If you use custom generation settings, please take screenshots of the What to Generate and Detail Settings tabs.

  • The error could be caused by a specific model. Could you possibly send it to us via email (lukas.knapek@quest.com)?
    DDL Reverse Engineering error

  • Please try to restart TDM and reproduce the error again, just to make sure it was not caused by the first error. Did you manage to reproduce again?

  • If so, once again, please send us the log file or the error information.

  • Also, could you send us the DDL file itself (via email)? We suspect the issue is model dependent and having the script would help us tremendously.
    As of now, we think the two errors have different cause (DDL Generation vs DDL RE). Once we have more information, we will see what we can do.

Regards,

Lukas

Hi Lukas,

I have sent you .elf file and ddl file. We were using defaults for DDL generation.

Workround supplied by Dell seems to overcome the issue.

Oracle model specific issue.

In the model turn off Verification of Name Uniqueness.

In TDM options increase Model.Max.number of messages to 200.