Toad World® Forums

Generate DDL script - Access violation


#1

When I hit the green play button “Generate DDL script” Access violation occurs. Tried to with no luck:

  • run as an admin
  • delete configs in AppData
  • run both x32/x64 versions
  • install current stable v6.4.4.42
  • install latest beta v6.5.3
  • default videorental model

Access violation at address 00000000005DD5BB in module ‘TDM.exe’. Read of address 0000000000000078


Error while generating change script
Error while generating change script
#2

Hello jiri,
we tried it and we can not reproduce it. Do you have eureka error log? On bug you should have dialog, where are more details about bug. If you provide it to us, we will able to analyze it.
Do you have default configuration? Default Enabled databases etc., or something specific?

Thank you
Daril


#3

There’s no dialog at all. Just Access violation message down at the bottom window. I am using default config.


#4

Hi Jiri,
if I understand it is happen when you try to show generate dialog (not generate from generate dialog). Did you do any customization of dialog in past? Do you have any custom package imported to TDM or some modification in MyPackage?
If you want to check custom packages, you need to switch on expert mode in Options, and after open package explorer. There you can filter system packages. After it you will see all other packages.

Daril


#5

Yes, I am hitting the green play button at the main toolbar. I have no customization and package installed.


#6

It is very strange. Can you try please do same with new Oracle 10 model and in new SQL Server 2016 Model?

Thank you


#7

Sure. I am trying the default videorental (Oracle 10) model and my model (SQL Server 2016), both are not working. I can run TeamViewer for you and have a phone call, if you like.


#8

Btw. What version of TDM do you use? The lates beta 6.5.3.10 or commercial 6.4.4.42 / 6.4.4.29? Does it happen in both version?


#9

Yes, it’s written in first post already.


#10

Hi Jiří, we have an idea … to generate DDL we are using JScript (user can use that to customize behaviour of Toad Data Modeler), that is usually enabled and working on most Windows machines by default.
Same scripting language is used in multiple subsystems like report generating, macros, custom form logic, …
Can you try to generate forexample HTML or RTF report or run some macro? If that wouldn’t work, we’ve probably found the cause of your problems.


#11

Sure, no problem. How to?


#12

From mian top menu of Toad Data Modeler select Model > Generate Report > Run… and go through the wizard with default settings.

To run some macro for example: with opened model run Main menu: Macros > Productivity > Add Entities
fill some name for new entities and hit OK - that should generate some new entities in Model Explorer (left hand side window)


#13

It’s stuck - not responding when I hit Model, Generate report, Run at the second page (Select Report), first page is working fine.

Macro - add entities access violation as for the generate DDL script:
Access violation at address 00000000005DD5BB in module ‘TDM.exe’. Read of address 0000000000000078


#14

OK, we’ve propbably found the origin of the problem. Seems like JScript is not working properly on your machine. You can try run very simple script (save the script bellow to script.js and doubleclick to run it - it should pop up dialog with message ‘RUNNING’):

WScript.Echo(‘RUNNING’);

Second way to check it is by running command wscript in terminal (key shortcut: WIN+R > command: cmd > OK)

That can be caused by various things:

  • some software like antivirus could block it
  • Windows Script Host is disabled, you can check this in windows registry and ON YOUR OWN RISK make changes (according to video bellow) to enable it.

#15

When I try to run this script I get 800a03f6 code error, but wscript is NOT disabled, I can run it.


#16

The problem is quotes (char(0x22) vs. char(0x93)), this command is working fine: WScript.Echo(“RUNNING”);


#17

We are using that single quotation almost everywhere, because it’s defined win JScript specification
(see: JScript Data Types: ftp://geo.ucsd.edu/pub/rheux/for_cce1_10/software/hyper%20access/cd/HAWIN32/DOCUMENT/API/JSCRIPT/4.HTM ) and I also tried here:

image

So something is wrong with your machine if this doesn’t work. I would like to help (and will be looking for solution), but for now, I’m out of options how to fix that.


#18

IMHO it’s related to jscript.dll exception. I’ve got v5.812.10240.16384, that came with latest Windows Update ( Windows 10 October 2018 Update (version 1809)) or latest SQL Server update (Cumulative update 11 (CU11) for SQL Server 2017).

What’s your jscript.dll version, please?


#19

To be precise after Microsoft Edge v44.17763.1.0 update (part of October’s Windows Update?). Your app fails during ComObject GetTypeInfo call, some parameter is null.


#20

I’ve got

  • Win10 version 1803 (OS Build 17134.345)
  • Edge 42.17134.1.0
  • JScript.dll version 5.812.10240.16384

that means I don’t have October Update 2018, that can be it, I will try it on some virtual machine and let you know

Anyway Win10 October Update 2018 is very buggy and even Microsoft stopped ditribution of it (https://www.theverge.com/2018/10/6/17944966/microsoft-windows-10-october-2018-update-documents-deleted-issues-windows-update-paused)