Toad World® Forums

Decimal point setting

Hi

I’ve a problem while extracting data’s from the database. I used to extract the data’s with a old SQL Nav version (4.3). It works fine. For some others tasks I used another version (6.7), because the old version was not able to open the new databases.

In V4, decimal point is the dot, in v6.7 decimal point is de coma, why ? I open the same database, on the same pc, and NLS_NUMERIC_CHARACTERS is the same : ., and NLS_LANGUAGE is set to AMERICAN

Where can I tell V6.7 to show (and extract !) a dot instead of a coma for the decimal point ?

Regards

Martin

Hi Martin,

I’m sorry currently there is no option in SQL Navigator to specify decimal point setting. I created SQLNAV-1834 to log this as an enhancement request. I will
let you know when it is implemented.

Thanks,

Vincent

Hi Vincent

Similar problem, but with the same SQL Nav version on 2 different PC’s. My colleague (our DBA) gets commas as separator an I get dots on the same database with the same SQL. We both have (normally) the same configuration.

How is this possible ?

Regards

Martin

Hi Martin,

SQLNav reads the format settings from Windows region and language settings. Would you please ask your DBA to check the decimal setting from Windows control
panel?

Thanks,

Vincent

Hi Michael

We have adjusted his regional settings, and now it works for him too.

Many thanks

Regards