Toad World® Forums

SqlNav rounds output


My friend has that problem with sqlNav 5.1 .:

select 1.26 from dual



I can’t simulate this.

So is there any option in sqlnav to change this?? If is I didn’t see it…



Does he use a login.sql or glogin.sql to set format preferences? What happens if you select from a column of type NUMBER instead of selecting from DUAL?


I will ask about logon.sql, but I don’t think he uses sqlplus. But he told me that sqlnav 4.4 works ok, meand doesn’t round.
select from table rounds numbers too…
I told him to check this issue in sqlplus directly, results will be next monday.


So sqlplus rounds output too. logon.sql and glogon.sql not founf on local disks.
Looks like this is winddows setting, but which one? He tried to change regional settings bu it didn’t help. Strange, sqlnaw 4.4 is not using this setting…?


Hi Piter,
Apology for a late reply. We did not have any luck reproducing the issue here yet. It is definitely relates to the envi settings…We have changed the underline component for Oracle connection from 4.5.(ODAC) ie. 4.4 use different comp (DOA)which might explain 4.4 works . Will keep trying here…and keep you posted.

What is the locale settings? Can you please provide us that info.

Thanks and regards,


So I found solution. Problem was in “Discoverer Home” set as active. Discoverer client runs scrips which sets session parameters. Afther changing active home to standard ORACLE everything works fine!!!

So this question is out of date…


Hi Piter,
Thank you very much for this info. It is a very good work here from you indeed . Will send you a virtual Oz beer when we can Piter.



THanks for that, but i prefer beer in real!

PS. People say that Polish beer is quite good…


The question is…
Can we buy Polish beer in Australia, so we can test this theory


Strange, Television advertising in my country, says tha Polish beer is everywhere!


Our QA team will try it next time we have a chance to go to the pub for sure and will let you know if it would past our test cases .