Toad World® Forums

Describe (F4) on package.procedure doesn't jump to the procedure like it used to

I’m using 12.8.0.11 and when I describe a package.procedure, I would expect it to open up the package and jump to the specified procedure just like it used to in previous versions (including 12.7). Instead, the package opens (in the package body) and the correct procedure is highlighted in the navigator but the focus is still at the top of the package. To navigate to the correct procedure I then have to click a different one and then back on the one that I want to it to jump to it.

In my options, Schema Browser --> Describe Dialogs, I have Stay-On-Top window outside of Toad / All Describes are contained in a single tabbed window / Allow ESC to close Stay-On-Top describe windows.

Thanks,

Mark.

I agree.

In 12.5.1.1 if I type fnd_request.submit_request into the editor and press F4 a Describe window opens up and it takes me straight to the submit_request function.

This does not happen in 12.8.0.11.

It’s fixed for next beta.

Indeed it is! Thanks John.

John, this seems to have become unfixed again! Can you please re-apply what you did last time? Thanks.

OK, I re-fixed it.

Thanks - confirmed as fixed in 12.8.0.21

John, it’s become unfixed once again! Noticed it in 12.9.0.9 and it’s still present in 12.9.0.10.

Fixed next beta

From: markagardner [mailto:bounce-markagardner@toadworld.com]

Sent: Thursday, December 10, 2015 7:55 AM

To: toadoraclebeta@toadworld.com

Subject: RE: [Toad for Oracle - Beta Discussion Forum] Describe (F4) on package.procedure doesn’t jump to the procedure like it used to

RE: Describe (F4) on package.procedure doesn’t jump to the procedure like it used to

Reply by markagardner

John, it’s become unfixed once again! Noticed it in 12.9.0.9 and it’s still present in 12.9.0.10.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - Beta
notifications altogether.

Toad for Oracle - Beta Discussion Forum

Flag
this post as spam/abuse.

Thanks Michael.

in 12.9.0.11 this is broken again.

while describing the package body (opened with F4) proc a is selected in navigator. I press Ctrl+F to search for a phrase, it scrolls to position where phrase is found and immediately scrolls back to procedure that was selected in Navigator.

Doesn’t do that for me - seems to be working as expected again (12.9.0.11).

Well, it does do that for me (in 12.9.0.11).

Another way to reproduce it is to use Object Search and search all your packages for something (e.g. a call to a specific routine), then in the resulting list of objects double-click on one to see the matches found in it. It shows the actual location briefly, then jumps back to the start of that function/procedure. If you hit F3, it does the same again. If you’re quick, you can hit F3 twice and get it to show the second occurrence (if any) before it scrolls back.

Best regards,

Niels

Can one of you experiencing the issue zip and send me your user files folder to michael.staszewski@quest.com? There are a few ways to visualize the Describe window and I believe I just ran through all of them and in each it’s selecting the correct node in the tree and moving the caret to the position in source. There may be some option configuration that’s bypassing the code I put in. I tested with a package procedure from the editor and from Object Search.

Thanks,

Michael

I missed the Ctrl+F portion. I was still in the mindset of the original issue in the thread. I can reproduce now. Thanks.

Michael, While looking at this code, could you please make sure that selected text stays selected? I tried to select ALL ( Ctrl +A) or just a one table name, selection disappears after a half of sec.

I believe that all of this is cleared up now. Describing is jumping to the correct node in the tree and the caret position is OK. Searching and selecting all does not clear the selection or jump. Let me know if anything is still amiss. Thanks.

Just installed 12.9.0.12 and the F4 functionality is working correctly once again. Thanks.

Yep, the case I described is also working fine now. Thanks!

Best regards,

Niels