Toad World® Forums

Displaying NCLOB columns

Hi, I need help to be able to display NCLOB type columns in my data-grids. I have TOAD ver 12.10.0.30 and ORACLE v 10.2.0.5.

I have checked both the “Preview LOB” and the “Deferred LOB” check-boxes, the respective columns do not show/display.

Any advice would be welcomed.


Table I am displaying:

int> desc SPLT_REP
Name Null? Type


SID VARCHAR2(6)
SPTY VARCHAR2(4)
TY_CNT NUMBER
WSP_TY NCLOB
ISP_TY NCLOB
WH_CNT NUMBER
WH_NET NUMBER
COMNT VARCHAR2(4000)

If you are looking in the schema browse and the LOB columns just aren’t in the results, go to Options -> Schema Browser -> Data Tab -> “Don’t select BLOB/CLOB columns”. Uncheck it.

Regarding Options -> Data Grids -> Data.

“Preview CLOB and LONG”, if checked, means you need to double-click on a CLOB cell in a grid to see the contents.

“Deferred LOB read” has to do with the timing on the loading of LOB data into the grid. I would leave this one unchecked.

THX that worked perfectly - didn’t think of checking “Schema Browser” settings.

Hi @JohnDorlon I have “Preview CLOB and LONG” unchecked, but still I have to double-click on a CLOB cell in a column to see the contents.

Is there any other settings that I am supposed to check ? SO that I can view the CLOB contents inside the grid rather than double-clicking to view it.

using toad 12.8

You should check (not uncheck) that option if you want to see the data in the grid without having to double-click it.