Toad World® Forums

Stop Toad from loading blobs


#1

Hi,

How can we stop Toad loading blobs if you go to a table in the Schema browser? It is pointless loading the blobs anyway, as you can see them, and makes loading a table with Blob VERY slow.


#2

Check out this option

Deferred LOB read

When checked, LOBs are read as they are displayed. This results in faster
initial load, but slower grid performance.

When unchecked, LOBs are read in with the rest of the fields. This results in
slower initial load, but faster grid performance.

NOTE: This option is ignored when CLOB/LONG preview is unchecked.

Default: Cleared


#3

BTW, it’s not pointless in all cases. If you want to extract the BLOB
values, you can in effect ‘see’ them when you have Toad write it to
a local file on your PC.

You can also use Toad to load the BLOB value for the row by pointing to a file.

Jeff


#4

Schema Browser -> Data Tab -> “Don’t select Blob/ Clob ”
fields.