Toad World® Forums

Drop View


#1

When I right click on a view and select drop as the view owner it does not drop. I turned on monitoring and no command is issued to the database. Not sure if this is intentional or not… Or of course it could just be me, but I did open a second navigator and tried it again. Version 6.3 of navigator against an 11. database.


#2

Hi Dale
Sorry for the late reply.
Does this issue still happen for you?

I tested this against 6.3 and on an 11g database as you reported and I have no issue dropping views.

regards

Lidia


#3

Yes it is still occurring.

create view daleview as select * from dual;

then expand explorer and right click daleview select delete and nothing happens. I am using 6.3.0.1833.

Not a big deal as the solution is to type drop view daleview…

BTW: I did this on both a 10 and 11 version of oracle…

Message was edited by: DaleFromLozier


#4

With 6.4 I could not reproduce that error (BTW right-click and DROP, right?)


#5

I’m with Filipe in that I always do a right click and choose drop, but I tried it in 6.4 with the delete key and it worked as expected. I got a prompt if I wanted to drop the view and when I clicked Yes, it went away.


#6

it is very odd, I right click, Select drop, nothing happens except the pop up menu goes away… I understand no else is having this problem. So I guess don’t concern with it now…
dropview.gif