Toad World® Forums

SQL Nav 6.1 - DB Explorer acting up


#1

Hello!

I use dual monitor configuration.
There are some issues happen if SQL Navigator is maximized on a secondary monitor.

The context menu on right mouse click acts really weird both on DB Navigation tree - selected database object become unselected and the displayed menu is all wrong.
The similar effects happen on SQL result grid - very hard to select a column or column heading.

primary.png

secondary.png


#2

Hi Alexey,

Sorry for my late reply. I haven’t managed to reproduce the issue in my environment. Did both of your screens have the same resolution?

Gwen


#3

The video card is Nvidia Quadro NVS 290, using Dualview (aka independent mode), driver version 6.14.11.6926 (12/13/2007).

The primary monitor is 1600x1200 on right hand side.
The secondary monitor is 1024x1280 in portrait mode on left hand side.

I tried to use DB navigator and I could use the right click on database objects and do things like DDL extraction to the objects I selected. Works the same way as DB Navigator in SQL Nav 5.5.4.

I’ll try to update the video driver and let you know if there’s any difference.


#4

Updated the driver, no change.

Here’s a way to reproduce the issue:

  1. Connect to the database, schema name ABC
    DB explorer shows
  • ABC@server (9.2.0.6.0)
    • ABC
    • PUBLIC
    • Other Schemas
  1. Left Click to select any of them, then right click to open the context menu. The selection stays where it was.
  2. Expand ABC schema.
    DB explorer shows
  • ABC@server (9.2.0.6.0)
    • ABC
      • Tables
      • Views
      • Sequences
      • Indexes
      • Triggers
      • Procedures
      • Functions
      • Packages
      • Package Bodies
      • Types
      • Type Bodies
      • Java Sources
      • Java Classes
      • Other
      • Database Links
    • PUBLIC
    • Other Schemas
  1. Right click on ABC - selection jumps 12 rows down to Java Sources and shows its context menu.
  2. Right click on Tables - the selection stays on Tables and shows tables context menu.
  3. Rght click on Views - the selection jumps 12 rows down to Other
  4. Right click on Sequences - the selection jumps 12 rows down to Database Links
  5. Same with Indexes -> Public and Triggers -> Other Schemas
  6. For all other rows the selection stays because there’s nothing after Other Schemas.
  7. If you expand Public or Other Schemas the selection will continue to jump 12 rows down as long as there’s a place to position.
  8. Expand Tables
  9. The selection stays in place when I do right click on any of the table names or Synonyms, Partitioned Tables, Other Tables or Store Tables.
  10. Expand Views or any other collapsed branch.
  11. Try right click on any of the branches - the selection jumps away.
  12. Expand Other Schemas, any other schema,
  13. Repeat the same exercise - Tables branch - selection works, Any other - fails.

#5

Hi Alexey,

Thanks for the detailed info. I can reproduce the issue now. It seems that the issue only happens if the primary monitor is on the right. I tried it with the primary one on the left and it works fine. Could you please try this as well and let me know if the issue still exists? I will raise a CR when I got the confirmation from you.

Gwen


#6

Yes, with the primary one on the left and it works fine.


#7

Thanks Alexey. Cr has been raised for this case.

Cheers,
Gwen