Toad World® Forums

Dropping procedure from decribe window does not capture parameter names


#1

See the screenshot - this code is captured when dropping get_line from describe. For long parameter lists it would be better to capture the parameter names too. This would be a good help to change one parameter after another to the desired input. Maybe a preference would be a good way to control the behavior.
image001.jpeg


#2

I’d additionally suggest to use the “=>” syntax, ready to be filled in:

SYS.DBMS_OUTPUT.GET_LINE(LINE => , STATUS => )


#3

Hi Torsten,

Have you tried Code Completion? If it’s on, when you enter an opening bracket after a procedure name, it will show you a list of possible parameter lists (more than one if the procedure is overloaded). You just pick one and press Enter, and it will be inserted in text (in a similar format to what you suggested).

Hope this helps,
Roman


#4

I don’t prefer the “=>” syntax, as this can gives problems when changing later the count of parameters. I prefer positional notation. But maybe a preference with a list?
Roman - for code completion we have an open bug, as after enter bracket no parameter list is shown here. This happens in the beta too.


#5

Hi Torsten,

I cannot reproduce the issue with parameter list. Could you please give us an example?

Gwen


#6

Have actually a service reqest with support open for this, as the support can not reproduce this too. Fact is that on my side after entering the bracket no parameter list is shown in 6.1 and 6.2 beta. See screen shot for example procedure and add bracket after select enable procedure. Maybe this is related to german installation, as we had errors, where these errors was only reproducable in non english environment?
lookup_par1.jpeg


#7

I’m not sure actually. It works fine for me. Maybe you should try uninstall, clear out the environment (registry, etc.) and reinstall again.

Gwen


#8

This is reproducable here on all clients and 3 different versions (6.1, 6.1.1 and 6.2 beta)!


#9

Hi Torsten,

After you typed in the bracket, did the x button at the top right corner of the code editor greyed out? Have you tried Ctrl+Space to force code completion?

Gwen


#10

The closing x does not disappear before as it does in other dot lookup operations.
Ctrl-Space does open the parameter dialog.


#11

By the way, the “=>” syntax in parameters is not optimal when you have to refactor later your code with defaults and so on. Therefore I prefer the positional notation of parameter.


#12

Parameter list comes not up in beta build 1317 too.


#13

Hi Torsten,

I got your support case about this issue with dot-lookup. I still cannot reproduce this issue but I had a wild guess that it may related to the role/privileges that get assigned to your user. Could you provide me with the extracted ddl of the user? (pay attention to select_catalog_role)

Regards,
Gwen


#14

Have reproduced this with 2 seperate computers of 2 separate users in our company.
Have reproduced this with 6.1, 6.1.1 and last 6.2 beta releases.
Have reproduced this with all used connections, eg. user scott, an almost sys user, a restricted user.
As you see in my support case - after entering the bracket no sql statement is fired anymore automatical.
So my first shot would be german environment, as we had another case, which was related to this too and was not reproducable before somebody has testet this with another non english environment (belgium).
I send you the extract of the user scott.
SCOTT_ddl.sql (466 Bytes)


#15

Hi Torsten,

Thanks for the info. I will test it with a German environment and see if there’s any luck. We’re having easter holiday coming up so I may not be able to get to this as early as I want to. I will reply back to your subcase early or mid next week. We will try to nail it for 6.2.

Thanks
Gwen


#16

Hi Torsten,

I tested this against a German environment but couldn’t reproduce the issue.
Does this package belong to the current schema or a different one?

Gwen


#17

As you see in the screeshot above this happens in a simple sql editor but happens too in a package or procedure editor regardless if the edited object is local or in another schema.


#18

you fotgot to attach the screenshot. :smiley:


#19

The screeshot is above - in the first entry of this thread.


#20

Hi guys,

We did a webex session with Torsten today and found out that the issue is with the keyboard he is using. Torsten is using German keyboard and in order to type an open bracket (, he needs to press shift+8. SQL Nav could not detect this, hence we have issues with the dot lookup. Roman is fixing this issue and it will be included in the next beta release.

If anyone has the same problem, please check it with the next beta when it’s available.

Thanks in advance,
Gwen