Toad World® Forums

Edit cell range in automation, toad data point 3.2


#1

I am trying to automate a query and place the results in an excel spreadsheet. Once I select the workbook and worksheet to deposit the new data, I noticed that the default range ( column range) is the entire workbook. My query returns 5 columns, on the 6,7, and 8th are vlookup formulas. When I run the automation, it over writes all of the columns and wiping out my vlookup columns. I have clicked on the data range until the worksheet selection, but the range is greyed out. Is there a way to just insert the first 5 columns and not overwrite the rest?


#2

Overwrite or append I believe are your only options but neither of those will help with data or formulas on the same row. Try putting your formulas on a different worksheet and only overwrite the data worksheet. Your formulas would point at the cells on the data worksheet but would not get overwritten (do not check the overwrite file box, but use the clear worksheet for the data sheet)…


#3

Or use a macro. We support firing macos before or after exporting results.