Edit package spec and editor comes up full pane

I have to be doing something wrong otherwise someone else would have seen this. When I am looking in my packages and right click down to editor, it brings up the editor in full pane mode within my workspace in Toad. When I just bring up the SQL editor it comes up in a window like I would expect. Maybe I have a setting wrong? Why would it behave differently like that when I come in from different ways?

Toad for Oracle Xpert (64-bit)

Hey Lawrence, can you provide steps so some of us can reproduce?

Are you right-clicking the package in the Schema Browser and choosing Editor?

F2 will bring the splitter to the middle in the Editor. Does that fix it?

it comes up different ways depending on what you are loading (SQL or PLSQL) and your desktop settings for these types of objects. You can save your desktop settings by clicking where the arrow points.

Can not replicate. I have seen it happen multiple times but I can't replicate. Not sure what was going on this week that I created 2 user confusion bug reports. I need a vacation.

Finally I have a minute to show how this happens. I am in the schema browser.

I then right click on a package, choose "editor" then "both" and it brings up SQL editor in full screen even though I have been using the editor already in partial screen.

I thought at first it only happens when I first started Toad but maybe it is the first time with each new session in Toad.

Thanks Lawrence

I'm not sure offhand what could be going wrong but I've logged this so I don't forget about it. Will look next week.


Hi Lawrence

I just took some time to look at this. I think I understand what is happening.

When you first open the the Editor and you are working in split-pane mode, I am guessing it goes to the "SQL" desktop. You can verify this by checking here:

The top/bottom pane split, as well as remembering which tabs are open at the bottom - these are all part of the desktop setting. There is also a PLSQL desktop setting.

So try opening the Editor now (maybe open a new tab if you already have an Editor open) and switch the desktop to PLSQL. Did the bottom section become hidden, so you are in full-screen mode? If it did, and you don't want this, then unhide it by hitting F2. Then you can save the desktop by clicking here

When you open a package from the Schema Browser to the Editor, the Editor tab for the packages will be in the PLSQL desktop. So that's the reason that you are seeing the Editor change from half-screen to full screen - the SQL desktop and PLSQL desktop have different settings, and Toad is switching desktops.

Each Editor tab will remember which Desktop is assigned to it. So you may see the desktop change as you go from tab to tab.

Perfect explanation. I was able to replicate the problem, correct it and then get the proper behaviour. Thanks for taking the time to assist.

You're welcome.