Toad World® Forums

editor marking text just by using cursor movement keys

Any time I highlight a block of text holding down the shift key and a cursor movement key, all subsequent movement of the cursor using arrow keys or home/end continue to mark text although i am not holding down the shift key. I have removed my .lay files several times, and have even removed and reinstalled TOAD. I desperately need help.

Sounds like shift lock is enabled. There’s a Windows accessibility option for it too that’s enabled by default on some versions (XP I think). If you press Shift something like 5 times in a row it enables. Try pressing shift several times. If that’s not it then
Google shift lock and accessibility options to figure out how to turn it off.

On 04/09/2015 02:27 PM, lylene.mason wrote:

editor marking text just by using cursor movement keys

Thread created by lylene.mason
Any time I highlight a block of text holding down the shift key and a cursor movement key, all subsequent movement of the cursor using arrow keys or home/end continue to mark text although i am not holding down the shift key. I have
removed my .lay files several times, and have even removed and reinstalled TOAD. I desperately need help.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Sticky keys, that’s what I was thinking of. Shift 5 times in a row can enable it. If that’s not it then go to Options|Editor|Behavior|Key mapping and click Restore Defaults to nuke any corruption to your editor key bindings.

On 04/09/2015 02:37 PM, Michael Staszewski wrote:

Re: editor marking text just by using cursor movement keys

Reply by Michael Staszewski
Sounds like shift lock is enabled. There’s a Windows accessibility option for it too that’s enabled by default on some versions (XP I think). If you press Shift something like 5 times in a row it enables. Try pressing shift several times. If that’s not
it then Google shift lock and accessibility options to figure out how to turn it off.

On 04/09/2015 02:27 PM, lylene.mason wrote:

editor marking text just by using cursor movement keys

Thread created by lylene.mason
Any time I highlight a block of text holding down the shift key and a cursor movement key, all subsequent movement of the cursor using arrow keys or home/end continue to mark text although i am not holding down the shift key. I have
removed my .lay files several times, and have even removed and reinstalled TOAD. I desperately need help.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Thank you, Michael. I have disabled sticky keys and toggle keys. The problem continues. It is only TOAD editor, and when I open a new editor tab, that one works fine until I use shift/move to mark text again. I’m afraid I may have a corrupt entry in my registry, but don’t know where to start looking.

There’s nothing in your registry relevant to Toad. Did you try restoring your key bindings?

On 04/10/2015 10:48 AM, lylene.mason wrote:

RE: editor marking text just by using cursor movement keys

Reply by lylene.mason
Thank you, Michael. I have disabled sticky keys and toggle keys. The problem continues. It is only TOAD editor, and when I open a new editor tab, that one works fine until I use shift/move to mark text again. I’m afraid I may have
a corrupt entry in my registry, but don’t know where to start looking.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Thanks. I will ask our service desk to take care of that for me.

Why not do it yourself? It’s something you do within Toad as mentioned in an earlier reply.

Michael

On Apr 10, 2015, at 1:52 PM, lylene.mason bounce-lylenemason@toadworld.com wrote:

RE: editor marking text just by using cursor movement keys

Reply by lylene.mason
Thanks. I will ask our service desk to take care of that for me.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

Hi Michael,

Facing the same issue which was been mentioned. while navigating between the code, code is being marked. i have analyzed it, it happens in this way,

  • Open the toad and open editor.

  • write some code and try navigating between the code and lines , here it wont happen.

  • Once do any operation to select the code using Shift. then cursor will hang in the same position for some time instead of selecting the context.

  • Post here the issue persist . it is very difficult to navigate between the queries. each time we need to use mouse to position the cursor.

Harish Thirunahari

Hi MIchael,

Its been a while , i kept checking for the solution from yourside. but no update i found on the above, Kindly suggest.

Thanks,

Harish Thirunahari