Toad World® Forums

Empty Default Filter For Schema Browser

I have searched all over for a way to fix this, but haven’t been able to find one.
I want the Toad for Oracle Schema Browser to have a blank default filter that returns nothing.

I’m working with a large database with lots of objects so switching from schema to schema, object to object, and changing the filter in the schema browser are all very slow. Each of those actions takes a long time every time I look for objects in the database.

I have been looking at View -> Toad Options -> Schema Browser -> Left Hand Side, but I haven’t come up with a way (by default and without editing the query in a dialogue every time before executing) to return no objects in the schema browser window. When I want to find something I want to be able to just enter something in the quick filter space.

Has anyone come up with a way to speed up the Schema Browser by just showing no objects by default?

I’m working with Toad for Oracle 12.7.1

Thanks

You could enter some bogus filter so you don’t get any results, and then to make it stick across all objects - r-click on the quick filter > Apply filter to all object types

The quick filter (the one that allows you to apply it to all object types) is post-query filtering, so that would not cause the SB to load any faster.

One option, for tables at least, is to go to the SB filter and check “Allow fetch of table names to be canceled”. Then when it starts loading tables, you can just hit cancel if you don’t want to wait for it to finish.

I just had another thought - you could set the Schema Browser to default to some object type that loads quickly. Right-click on the object type dropdown and choose “configure”. If you choose an database-level object (users, roles, tablespaces, etc) instead of a schema level object, then you can change schemas in the SB without it refreshing the list. So you could change schemas first, then change to the object type that you actually want to see.

If none of this works for you, I could maybe add a “don’t auto-load SB” option in the filter, so you could choose your schema and object type, then hit “refresh” to load it.