Toad World® Forums

Enhancement about Reverse Engineering Wizard


#1

Hi

I tried to be lazy, I have Stored Aliases for one of my database. E.g. Called “A”. From the same database Server I have several Database. E,g, Called “A”, “B” …etc.

Today I tried to load the Stored Aliases and tried to change the database by selecting Initial Catalog to use to “B” and then Click “OK” and CLick “OK” again on Connection String dialog box. Then I click Next all the way until the stage “Tables”, It still selecting the table from the Database “A”. I think it is something that could be improve. I tried again by on the Connecting stage, and click on “Test Connection” button. It seems to work fine (sometime). I think it may be easier as soon as the user click on the button on the “Connection String” dialog box and it will test the connection to make sure it refresh the selected database.

Please let me know if you want me to explain more.

Many thanks

Chi


#2

Hello Chi,

This is a bug. Thanks for your notification. We will deal with it. CR # 49 207.

Thanks again,

Vladka + TDM Team


#3

Hello Chi,

I’d like to ask you some questions regarding the problem to be sure we take the same steps as you:

  1. Do you reverse sql server 2000 or 2005?

  2. Do you:
    a) Select Alias, click Load Alias and then click the Previous button to get to the step Connecting
    OR
    b) Select Alias and click Next, Next… to the step Connecting?

  3. Please see the attached screenshot of Data Link Properties dialog. Is it here where you change the database?

  4. Do you change anything else here?

  5. Do you enter the same passwords in the Data Link Properties dialog and the RE Wizard? (You can have db without a password…)

(I select the db - sql server 2000, test the connection, confirm password in the wizard, go to step Tables and appropriate tables are listed there.)

Thanks for the details.

Regards,

Vladka


#4

Sorry, I’ve forgotten to attach the file. Here it is.

Vl.
dbselection.pdf (109 KB)


#5

Hi Vladka

Sorry to reply you late

  1. I reverse SQL Server 2000
  2. I Select Alias and Click Load Alias then Click on Previous Button to get to the Step Connection
  3. Yeah There is where I change the Database
    and I re-enter the password in the Data Link Properties dialog and Connecton Dialog.

Yeah. It works sometime when you Click on Test Connection and Click on Next, but sometime it just did not pickup the new connection.

Please let me know if you want me to explain more.

Many thanks

Chi


#6

Hi Chi,

Thanks for the confirmation. I’ve forwarded the case to our testers to accomplish further testings. Thanks again.

Regards,

Vladka