Toad World® Forums

Error Checking out file E:\svn\UnitStat\sql\webapp.pkb

Howdy!

I am trying to configure Toad 11.6 to work with SVN i have tortoise SVN 1.8 installed. through the tortoise repository browser i’m able to check files in and out so i believe the svn is setup correctly.

I had set my toad source control to svn , i had to use the --force-interactive global option , other wise the login would fail with an error about it not being in interactive mode. seemed simple enough.

so now I can view the SVN, and i see my oracle files (a package pkb and a pks) but when i click on open , or get latest or even check out i get the same error

"Error Checking out file E:\svn\unitstat\sql\webapp.pkb " when i look at that path , there are no files in that directory

Just for discovery reasons i copied down those 2 files (using tortoise svn) and placed them in my local directory. … Now i’m able to open those views from the svn browser view from with in TOAD.

so I also tried creating a new file New1.sql and saved it in that same local folder, and i tried to add this to the repo via the TOAD “add file to source control” button, but i get the following error :

Error: error adding file E:\svn\unitstat\sql\new.sql

so it seems as if Toad is having a problem reading and writing to my hard drive.

and more strange behavior … so i made a 2nd new file (new2.sql) and checked this into SVN using totoise. i refreshed the svn view from toad and i see the file. i double click it to open the file.

new1.sql was deleted from my local folder. i get no error message, but the file does not open in the toad IDE

I try a 2nd time to open new2.sql form the toad svn view, and i get the same error i started with : toad message “File C:\users\aradmeac\appdata\local\temp\new2.sql does not exist” very odd because that is not my local working directly that has been set.

What should my next step be ? any ideas for fixing this?

I also get an error trying to add files to the svn