Toad World® Forums

Error in exporting and copying / pasting data into Excel

I'm running Toad Data Point 5.0, and I'm encountering an error where I can't export a data set that is 5,240 rows to Excel. I've encountered this same issue several times, and I typically experience the issue somewhere in the 4,000-5,000 range of rows. Anything beneath that is fine. I'm also not the only person at my organization to encounter this problem.

When I experience this error when copying and pasting data into Excel, I find that nothing actually copies into my clipboard. I am prompted to ask whether I want to include headers or not when copying the data.

When I try to export the data to Excel, I receive the following error upon completion of the export: "Export is cancelled - Object reference not set to an instance of an object. Export is cancelled." Then, I see an export summary of the results stating that only 2,048 rows exported, and that the export was status is "Cancelled." However, I do see that the export actually occurred, and that 2,048 rows are found in the output file.

image

As I mentioned, I have encountered this issue with several different data sets. I have tried to export to my desktop, to a location in My Documents and to other places, and I experience this same issue in each case. I'm also not the only person at my organization who experienced the issue. Importantly, I started to encounter it when I was given a Windows 10 laptop with Toad 5.0 installed. Prior to that, I had a different version of Windows and an older version of Toad, and I never encountered this issue.

We're at a loss as to how to handle this. Does anybody know what might be going on and how to troubleshoot it?

Thanks,
Chris

Best to take this one to our Support team, but at least to get us going on the troubleshooting trail in the meantime...

  • Data Source where the data is coming from?
    (e.g. Oracle, Hadoop, etc.)

  • Was the datasource connection interrupted within TDP, by chance?
    (e.g. I have seen similar issues where connection to the back end data was lost, then reconnected, and then client products (not just TDP) sometimes have issues with "leftover" grids and queries that are no longer "referenceable objects" within the client)

  • Steps you're using to do the export?
    (e.g. using the Export Wizard? Choosing "Quick Export" directly off a data results grid?, etc.)

  • If another colleague performs the same import steps on the same data source, do they get the same result?
    (e.g. looking here to see if the Import hiccups at exactly the same row in Excel. If so, could be weird ((control?)) characters in the data causing some weirdness that Excel doesn't like... :roll_eyes:

Hi, Gary – Here are the responses to your questions:

  1. The data was coming from Oracle
  2. It doesn’t appear to be getting disrupted. While I mostly work remotely, I’ve had this issue occur both at my home and in the office (where I was hard-wired into the network). As I mentioned, another colleague has also experienced this.
  3. I’ve taken two approaches to exporting data:
    a. When I actually use the Export Wizard, I encounter the issue that I mentioned earlier
    b. When I use the Quick Export function, I receive the same error
    c. When I highlight the result set and try to copy and paste the data, nothing actually copies. The only text that copies is whatever last thing in Word, Excel, etc. I might have copied
  4. My colleague and I have experienced this same issue in the same manner. We have also experienced this with multiple data sets many times now. The data sets are typically just a few columns in size (or sometimes either one column). To control for special characters (which, I’ve verified to not be in our data), I have also used the REGEXP command to exclude special characters. When I do so, I encounter the same issue.

By the way, there is one last wrinkle to this process: I even find that I cannot fetch records that number over a few thousand or so. I experience this issue when I select “Read all rows.” Here is the error I receive:

System.IO.DirectoryNotFoundException
Could not find a part of the path 'C:\Users\Chris\AppData\Local\Temp\5\393e959f-81bd-4e72-adc4-629413b776fb.tmp'.
Stack Trace:
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize)
at Quest.FastData.FastTable.GetTempFileName()
at Quest.FastData.FastTable.RowCollection.SerializeRowData(Object data, FastSerialize serializers)
at Quest.FastData.FastTable.RowCollection.<>c__DisplayClass50_0.b__0(Object )

If it helps, I’m using Toad 5.0.6.97

Let me know if you want to know more about what I’m experieincing to help troubleshoot the issue. Thank you.

Chris

This does sound strange to me. Let's do this to keep things simple... upgrade your TDP 5.0 to the latest version and see if that helps resolve your issue. If not, I would definitely take this one to Quest's Support team. We probably would have heard from other TDP users on this forum by now if they have experienced the same, or similar, issues.

Thanks, Gary, I’ll do that. I’ll let you know if that resolves my issue.

image001.jpg

Absolutely, I'm curious to understand what the issue is...

I have the same issue with latest 5.3 running on windows server 2016. Didn't start happening untill last month when windows updated.

I stated to notice this once my Windows was updated, too.

Hi, Gary - I re-installed Toad and encountered the same issue. Also, I should mention that I encountered the issue after a Windows upgrade, just like what the poster below mentioned.

I've pinged our dev folks about this one, but encouraging you to take this issue to Quest Support, especially if we're seeing other folks having similar problems after a Win upgrade. Thanks.

Thanks, Gary, I submitted a support request.

Super... looks like we're not seeing an "epidemic" of issues due to Win upgrades, so curious for our Community to hear what the problem/cause/fix is here, in case other users have similar issues.

Hi, all - Quest's solutions team resolved this issue. For whatever reason, my "Serialization temporary folder" contained the characters "\s" at the end of the file path. This prevented Toad from locating this directory, which is why I was unable to fetch large record sets.

Here are the steps to fix the problem:

1.Go to Tools | Options | Database | Script Results Change the "Serialization temporary folder" to: C:\Users\CustomerUserNameI\AppData\Local\Temp

2. Verify that you have access to this path via File Explorer.

3. Restart Toad product and verify results.

Thanks to Jose from the Solutions Team for figuring this out!

Awesome... glad we discovered the culprit. Now, just wondering how the issue is/might be related to Win OS updates...

Great question. We're stumped as well...