Error message when opening Navigation Manager

I just installed v5.7.0.405 on a new laptop, and followed the instructions at Migrate Settings to New PC to move my settings to the new laptop - I copied the contents of c:\users\application data\quest software\toad for data point 5.7" on my old laptop to the corresponding folder on the new laptop. Before I copied these files, TDP opened fine with no errors. Now, the first time I opened it, I got this error:

Could not find a part of the path 'C:\Users\dbean\AppData\Roaming\Quest Software\Toad Data Point 5.3\ModuleSettings\ProjectManager.tpf'.
Stack Trace:
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
at Quest.Toad.ProjectManager.ProjectContents.get_RootItem()
at Quest.Toad.ProjectManager.ProjectManagerControl..ctor()
at Quest.Toad.Analyst.AnalystBrowserControl.InitializeComponent()
at Quest.Toad.Analyst.AnalystBrowserControl..ctor()

The Navigation Pane opened, but it was empty, so I tried closing it - now, TDP opens without error, but I get the error if I try to open the Navigation Pane. I can open the Connection and Object panes without issue - those are the only other components I've tried.

Seems your new TDP 5.7 is still pointing to this older TPF file from TDP 5.3, and is not finding it.

Probably first thing to do is to check your TDP options (see snap below) and make sure TDP is pointing to a valid Project File (TPF type= Toad Project File). If the old TPF file still exists, you might want to copy it into the new location that TDP is looking at to find it
(guessing c:...\Toad Data Point 5.7\ModuleSettings).

Other option is to see if you can start a new Project within the Project Manager panel.

1 Like

Thanks! There was a reference to the 5.3 folder hiding out in the Project Manager Folder path. I changed the path to 5.7, and that resolved the issue.