Toad World® Forums

error when opening session browser

Hi,

I am getting “Stream read error” with below exception details when tried to open session browser in Toad

Exception:


2.1

Date : Wed, 14 Sep 2016 02:38:04 -0400

2.2

Address : 0043B1B1

2.3

Module Name : Toad.exe - (Toad for Oracle)

2.4

Module Version: 10.1.1.8

2.5

Type : EReadError

2.6

Message : Stream read error.

2.7

ID : 14F3

2.8

Count : 1

2.9

Status : New

2.10

Note :

can you please suggest me the steps to resolve this issue.

Thanks,

Vijay

Go into your User Files folder (Probably something like C:\Documents and Settings<windows username>\Application Data\Quest Software\Toad for Oracle\10.1\User Files). Then go down one more folder into the GUISettings folder.

Delete every file in the GUISettings folder that matches the pattern SessionBrowser.*

That ought to do it. These files just contain saved settings for the Session Browser. Deleting these files will restore the Session Browser to its default state.

Sorry John for late reply, I could not able to get the solution

I am using toad in my client VDI(Virtual Desktop Infrastructure).

  1. In C:<windows username>\Application Data\Quest Software\ – I cannot able to see any details related to toad as my toad for oracle folder is on desktop and in this folder if I go into clientfiles\userfiles\ , I didn’t find GUISettings folder. In userfiles folder I can see only TOAD_SESSBROWFILTERS.INI, even after deleting this file, i can’t able to open session browser in toad.

  2. Schema names and connectivity related details are present in C:\oracle\ora102 and there are many sub folders here, could not able to get what need to be modified.

To make sure you are looking in the right place, from Toad’s main menu, go to View -> Toad Options. In the left hand side of the options window, click “General”. On the right, in the “Application Data Directory” box, click “Open folder”. You should see GUISettings in that folder. Close Toad before you delete/rename the folder.

Thank you John… I can able to open session browser now. :slight_smile: