Toad World® Forums

Excel import without quotes

Hi,

The excel import wizard generated the following script:

CREATE TABLE BIC.PARKEERGEG ("Datum " DATE,
"Tijd " VARCHAR2(30),
“Deurnr” NUMBER,
"Deurnaam " VARCHAR2(64),
“Microsectienr” VARCHAR2(50),
“Pasnr” NUMBER,
"Afdeling " VARCHAR2(71),
“Aantal” NUMBER,
"Functie " VARCHAR2(73),
“Regeling” VARCHAR2(50),
“Maand” NUMBER,
“Weekdag” NUMBER,
“Jaar” NUMBER,
“Weeknummer” NUMBER,
“Uur” NUMBER,
“Dagdeel” VARCHAR2(100))

This script, executed in oracle 8.1.7, got me an ORA00972 error. This can be solved by removing the spaces in field names like "Functie ".
However, I would like the script generator to generate a script without quotes. This will also solve the problem.
Is this possible?

I can see the real issue is with the spaces. I’ve made the change to trim them in create table DDL. However, we cannot remove the quote since the column names can be reserved words or have spaces in between, etc.

Thanks, trimming is also an option! I understand you’re able to change the create table DDL? If so, how?

There isn’t a way right now to change the DDL. We tried only quoting names that needed to be quoted yesterdaya and the code was not happy about that. The trim fix will be in the next Beta.

Debbie