Toad World® Forums

Exchange connections in Workspaces

Hello,

I’m a heavy user of the workspace feature of toad. Now our DBAs are planing to replace the connection strings in the tnsnames.ora (because the host name will change due to a hardware upgrade). Unfortunately My saved editor tabs do not load as long as the connection for them is not established. Therefore I will not be able to open my saved editor tabs.

I’ve tried to search & replace the connection strings in the file “Workspaces.dat” which rendered it unreadable for Toad.

Is there any way to replace the connections for the saved workspaces?

Best regards
Quirks

Hello Entropy,

I have run into a very similar issue.

Wonder if you got any traction on this issue, no one has replied but have you been able to find a workaround?

I use workspaces a fair bit. I have one workspace that is only half loading and then it hits a database that is not available and it stops completely, it does not load up the rest of the workspace. I have allot of critical details about a current project I am working on in tabs that are not loading because of the connection error, and I do not know what database it is failing on. I have about 30+ databases to choose from so just not practical to try and figure which one it is.

regards
Craig

I did manage to find a convoluted workaround to identify which database was failing. If anyone is interested let me know and I will post it up.

Turning on Spool SQL before attempting to restore a workspace should show you which DB Toad is attempting to connect to

Thanks John, I hope this is not a dump question but where do you turn on Spool SQL, is that an option within the TOAD options as I cannot find.

regards
Craig

Sorry, I should have mentioned that.

Main Menu: Database -> Spool SQL -> Spool to Screen.

It will go to the output window at the bottom of Toad (unless you moved it somewhere else)

1 Like