Toad World® Forums

[14.2] Workspace Editors open on wrong connection

Hey Quest,

long time no see :wink:

I had a problem using my saved workspaces with 14.1 and just gave 14.2 a try. Unfortunately, there is still the same problem. When I open a workspace, not all connections get an Editor (it is set to One/Connection btw) but the last one seems to get "all the Editors", resulting in several opened SQL tabs:

The packages should have been opened on the first connection (TOSCA@DSKURI) instead of the last one, too. See the first connection for reference:

It shows the SQL tabs / packages but no Editor (Show Buttons for Current Connection is enabled). When I open up a new Editor on that connection, it opens it correctly, but my packages got loaded from the wrong connection.

grafik

EDIT: This happens with a "fresh" upgraded Toad, is still there after "Import User Settings" and also saving the corrected workspace with the new Toad does not solve it (its just wrong a bit different).

Cheers,
Julian

Hi Julian,

I just tried this:

  1. started with a fresh user files folder
  2. made a connection, open an editor, type in a few characters and opened a package
  3. repeated step 1 with a different connection
  4. repeated step 1 again with a different connection
  5. saved the workspace
  6. restarted Toad
  7. loaded the workspace....everything came up as it should.

Can you modify my steps above to reproduce the problem?

Hi John,

well, I really hoped I could avoid setting up 30 workspaces again (plus all the other settings in the user folder). So I tried your steps with my current profile. Same result. Opens the packages and Editor tabs always on the "last" connection saved.

But I guess I found the culprit: I disabled the setting "One/Connection" for the Editor. That seems to do the trick. It opened Editors on all connections and the tabs were on the corresponding connection, too.

Enabled it back again and can reproduce the behaviour. That is how I can reproduce it (all other Window types are unchanged):

grafik

Edit: Also this is enabled, as I said before. Maybe that is interfering with the new way of workspace loading? I can see all connections being opened and only after that the Editors are opened.

grafik

Cheers,
Julian

Thanks Julian. Sorry I didn't check one/connection before. I was thinking it was the default setting.

You didn't really think I would cause you to lose all your workspaces, did you?

You can revert to your old user files and get all your workspaces again like this:

  1. shut down Toad
  2. browse to C:\Users\YOUR_OS_USERNAME\AppData\Roaming\Quest Software\Toad for Oracle
  3. find the 14.2 folder, rename to 14.2_x or whatever
  4. rename the 14.2_bak folder to 14.2

Start up Toad and it will be as before.

Haha, no. That was just general speaking as in "I wont switch if that means starting fresh". I sure as hell have my "old" 14.0 Toad and profile still rolling :wink:

1 Like

I can reproduce the problem with one/connection set.

I'll log it and have it fixed in an upcoming beta.

Thanks for reporting it.

Great, thanks. I just wish I had done this with 14.1 already, so I dont have to wait for 14.3 now...

Well, I guess I could just disable One/Connection and see how that feels on my workflow

1 Like