Toad World® Forums

Export connects, remove one user connection, import-user is still present

Hi,

Tested on Toad 12.7.0.51.

I do not know if this is a bug or not but want to remove all connections for one user.

  1. I export connections to flat file (on login dialog)
  2. Edit file in a way to remove al
    [LOGINxx]
    User=yyy
    entries (until GUID line)
  3. Save the file
  4. Import through connections dialog
  5. Restart Toad (or not—same)
    but entries are still present.

If this is not a bug, then could I get the answer how to delete all connections (many databases) for just one user?

Brg
Damir

I can’t comment on whether it’s a bug or not, but assuming I understand your request correctly, if you order the connections in the New Connections screen by user (or group by user), then it’s just a matter of highlighting all the rows you want to delete and then hitting the delete button on your keyboard.

Hi Boneist,
I have Toad with 40-100 databases on several different computers.
One user should be removed from all saved connections on all computers.
I thought that export/edit text file/import will be OK, but it is not-user remains in the connections.

Hope now is ll more clear.
Brg
Damir

Bumps … any help on this issue or it is just not supported?

As Boniest said, just put the login screen in grid mode, then sort by user, select the ones you want, and delete. It should only take a few seconds, and no need to import/export.

I’m having trouble doing this as well. I highlight the user/connection but there’s no option to delete. What am I missing?

–Well I feel stupid. I was looking for a menu option, turns out highlighting the row to delete and depressing the ‘delete’ key did the job.

Use the delete key on your keyboard.

John,

Just found it. Somedays I wonder if I should be allowed to use a computer…

K.