Toad World® Forums

Export data (1 row) and memory

I periodically have to get big chucks of XML – 100 to 300 MB – from database
CLOBs or BLOBs to flat files.

We (finally) moved from 9.7 to 10.5 recently, always behind as usual, and I’ve
started getting out-of-memory errors when I do that. Physical machine hasn’t
changed.

My normal approach probably hasn’t been the most efficient. With 9.7, I would
typically select the CLOB column for the record of interest and SaveAs, now
ExportData. On 10.5.1.3 that’s giving me the out-of-memory popup.

I’ve tried the ExportBlobs, but it just hangs. If I have a BLOB column, I can
open up the popup editor and save it without any trouble. But opening a 150 MB
CLOB with the popup editor just means sitting there for a day or so while it
tries to parse.

Before I generate my bundle and head over to support, any suggestions on
settings I should try? Some of mine might have gotten confused during our
upgrade.

Thanks,

– jim

James F. Hudson

Wisconsin Department of Natural Resources

Madison, WI

(608) 267-0840

Hey Jim,

I just tried ExportBlobs with 10.5. For a 100Mb CLOB, it took about 20 seconds.
How long did you give it?

-John

Just took another try. Started Toad fresh. Selected my row which has a 140MB
CLOB. Right click, export Blobs, selected the CLOB column, identified a
directory on my local drive, executed. So far, 100 minutes so I’m killing it.
Made a 1K file

Database is 11.1. Plenty of disk space on my machine. Haven’t tried another PC
here yet. But if you don’t have any trouble exporting a CLOB that big, I’ll try
that and then call support.

– jim

I tried with a larger clob and now I’m having similar problems. I’m
working on a solution for Toad 11, but I’m not sure of anything you can do
with T10. You might have to write a pl/sql block to spit it out to file for now
(that would probably be faster than Toad anyway)

Thanks. I’ll just try to keep my LOBs down closer to 100MB than 150. And work
around it for now, with PL/SQL if necessary.

– jim

I’ve improved this for the next beta. It just wrote a 320Mb file in about
40 seconds. It’s probably just a matter of network speed at this point.