Toad World® Forums

Export Dataset - Access Denied Error

Hi,

We are using version 10.0.0.41 and have a problem when trying to use the Export Dataset function.

First thing Monday it worked fine and I was able to export 30k+ rows to a TXT file. I then changed the SQL re-ran and tried to save as a new file but get an ‘Access Denied’ error.

I have tried saving to different locations, network and local. I have tried cutting the data down to a single row. The networks team have checked the permissions but all users appear to have had this issue.

Attached is a screen print of the error message and the call stack and error information.

Any help would be greatfully received.

Thanks in advance

Alex

TOAD_Error_2.doc (68.5 KB)

First off, there were 2 patches after 10.0.0.41 release. Please go to
Quest’s support website and get 10.1.1.8.

Looking at your call stack, it appears that Toad is checking the windows
scheduler. Is your scheduler service running? In that release, I think it needs
to be, or you’ll get an error. I am pretty sure it was fixed in the patch
though.

-John

Thanks, I will pass that info on to the necessary bods and ask them to update our software.

Cheers

Alex

Hi,

This has now been resolved. Apparently there was a permissions issue on the scheduler folder that Toad was tring to access.

Cheers

Alex

Guys ,

thanks for sharing all these informations , could you please state to whom to give permissions on the task scheduler ??

Thank you

By the way ,

the problem was resolved by regenrating the TOAD part in the user profile .

check this article support.quest.com/SolutionDetail.aspx

Regards