Toad World® Forums

Export delimited data with one column table bug


#1

Toad 13.1.0.78
when you have one column table (didn’t test for query that return one column) export "delimited text, do not place delimiter in resulting file (clipboard).
When you check “Include delimiter after last column”, export has delimiter but not on the last record, as it should be-again bug.
Brg
Damir


#2

It does work, but it does not include the delimiter on the last row (as designed)

try
select 1 as data from dual
union
select 2 as data from dual;

you’ll see a delimiter after the 1 but not the 2.


#3

As I said, I tried with table with one column.,
in that case it has a bug as described.


result is quotted values with no delimiter.
P.S.
Do you need table description?


#4

It makes no difference if you select from a table or a view (dual is a view). We have to use a query to get the data either way.

Are you talking about the “include delimiter after last column” option, or the “string quoting” and “number quoting” options? Your first post sounded like one, your second sounds like the other.

I used your settings to export a table with one column, two rows, and got what I expected. (below)

‘x’
‘y’

Please post the result you are getting and what you expect to see.


#5

I see the “include delimiter after the last column” checkbox is not checked in your screen shot. Do you get what you want when you check that box?


#6

Hi John,
if you think that all is ok, and i make some logical errors in definition, then forget this post and leave app as it is.
I will try to place once more everything:


  1. when you choose ok, and pastre exported records you have:
    2

So do you see any delimiter?
I’m sorry I don’t.
So if is still ok for you, please forget this topic and close it as non reproductable.
Brg
Damir


#7

And again, when you check “Include delimiter after last column”, you get delimiter.
For me delimited export if you have one column should have delimiter regardless it is the onlky column…or I have wrong logic.


#8

If there is only one column, then of course, it is also the last column.

Typically we don’t include delimiter after the last column, since the line feed separates it from the next record. But for those who want it, we have an option to include it.

However, even if “include delimiter after last column” is checked, we don’t include a delimiter after the last ROW, (Think of a list of email addresses, you don’t include a semicolon after the last one)


#9

I think that if I automatically include delimiter after a 1-column export, then someone will tell me that it is a bug when they have the “include delimiter after last column” option UNchecked.

And if I take away the option completely, someone will complain for sure.


#10

and if I take away the option completely, someone will complain for sure.
Do not think so, “fixed length”, without headers is option that covers that type of export, right?

on the end i think that in one column grid export, when delimited type is chosen, “include delimiter after last column” should be checked and DISABLED.
this is GUI that is far more logical to me.