Toad World® Forums

Export NCHAR or NVARCHAR column in Insert Statements

I’ve some NVARCHAR2 columns in my table and I would like to create INSERT statements about the rows. Can you give me some instructions how can I resolve this issue in TOAD not to see “?” chars in the destination database? The output format must be INSERT statement, the original and destination charset of databases are Latin-2, which doesn’t support for example € sign just in NCHAR columns.

Do you support n’ notations in any way, or I should always set NLS_LANG property in my scripts regarding to the inserted data? (nls_lang set to al32utf8)

thanks for your help.

I thought we put N’ in there but I don’t see it in the code. Looks like you should set the NLS_LANG in your scripts.

And can you add this feature to Export Dataset when extracting NCHAR/NVARCHAR/NCLOB column types as INSERT/MERGE statements?


yes, N’ will be there next beta for those datatypes. If there is any reason why it should be an option, let me know.

Just the version of Oracle server could be the problem. If I read correctly this n’ was introduced in 10g, and you should set ORA_NCHAR_LITERAL_REPLACE=TRUE before using it, am I right?

I don’t see any other reason to be an option this one for NCHAR columns.

Sounds like it should be an option then. I know the version of the database that the data is being extracted from, but that could differ from the database that the script is to be run against (could be a different DB)