Toad World® Forums

Export the results of a query to csv


#1

I’m new to Toad. What’s the easy way to export the results of a query to a csv


#2

Rt-click in the grid, then choose “Export dataset”


#3

Thanks - I got it done


#4

I don´t have a option to import to CSV. Need I plugin? Thanks!! (I don’t speak english) :wink:


#5

No, you don’t need a plug in. Choose “Delimited”. It’s the same as CSV


#6

Hello John, I’m a new in this community… I get an opportunity to say hello to everybody.

I did the same but I had more than 2 millions records, I tried to choose “Delimited” and I rename the ouput like for exemple “daly_record.csv” … but the excel show me only on tab withe 65 000 records… how can I find others

Thank you for a help.


#7

Hi Christoky,

Toad should be exporting all of the rows to to file. If it’s not, let me know. How Excel imports it…that’s up to Excel. Sorry, I don’t know.

You could try just exporting to the Excel format from Toad instead of delimited text - make sure your file extension is .xlsx, not .xlx.

-John


#8

It sounds like you are running an old version of Excel.

Older versions had a limit of 65000 records. The newer versions do not have this limitation.

Can you tell us what version of Excel you are running?

-Mark


#9

hi John Dorlon and Mark Kurtz
thank you for your quick reply… For you Mark, I use Excel 2010 for laptop and 2013 for one an other.

John, let me explain how I’m trying to export my data using the ‘Save Grid Content’ (of Toad):

  • Export Format : “Delimited Text”
  • Output File : myData or MyData.csv (this is the name of output file)
  • String Quoting : “Double Quote String Columns”
  • Character : “comma”

I have more than 2 millions records… when I tried to open the output file with excel, I get about 1 048 576 records only, and the error message from Excel is : “file not loaded completely”… but my file’size show me that there are more records.

knowing that Excel cannot exceed 1 048 576 records, how can I do to export all my data?

Regards!

  • Chris Toky

#10

In Toad for Oracle, there is no “Save grid content” that I’m aware of. The menu item is “Export Dataset”. And the field labels that you are telling me about are not named that way in Toad for Oracle either. Are you using some other version of Toad? Toad Data Point, maybe? That’s a different product, and it has a different forum.

In any event, you could get that data into Excel using Toad for Oracle the way I described before. Toad will put 1,000,000 rows on the first sheet, then move to the next, etc. But you are going to need a lot of patience (and memory) to put that much data into Excel. Maybe we can suggest something better if you let us know what you are trying to accomplish.