Toad World® Forums

Fixing a "Toad Data Modeler - Internal error"

Hi all,

I’m totally new to Toad and pretty new to databases. I’m trying to use Toad Data Modeller but am completely stuck.

I have two connections to two separate databases in Toad for Oracle 11.6. These are saved in the TNS Names file.

I am trying to use Toad Data Modeler 4.3 to reverse engineer one of the databases. I set up a connection to it using Oracle 10g as the Data Source and choosing a Native Client Connection. It finds the database correctly and I log in using my username and password. After choosing the Reverse Engineering option, I can choose to either use “Live RE” or “Reverse Engineering”. However, both of these options fail with the same error message:

Source: Toad Data Modeler - Internal error
Script: REDataMigratorDBOR
Description: ORA-00904:“T”.“DROPPED”:invalid identifier

Row: 5250
Column: 3

Callstack:
“REDataMigratorDBOR” from package “Object RE Database for Oracle”
“REDataMigratorDBOR” from package “Object RE Database for Oracle”
“REDataMigratorDBOR” from package “Object RE Database for Oracle” (NOTE: THIS THIRD LINE ONLY APPEARS IF I CHOOSE “REVERSE ENGINEERING” OPTION, RATHER THAN “LIVE RE”)

I have to clue where to go from here, so any help would be appreciated.

**Edit: If it makes a difference, I notice that I can connect to the OTHER database with no issues. This might be because of how I connect. The database I can connect to I simply log in and view all the info I want.

The database I’m struggling to connect to, when I log in I have no access to any tables/views. Instead, I have to scrolls down to “Other Users” and choose to log in as a user for that particular system. Then I can view everything (hopefully that makes sense). I’m just wondering if this additional step is what has caused the issues.

Most commonly this error occurs when trying to reverse engineer an Oracle 9i database with a connection that is set up to work with 10g. Can you try setting your connection type to 9i and see if that works?

Brilliant. That seems to be it. I just assumed 10g would be compatible with 9i. I’ll post again if I’ve any trouble but for now, thanks!