Toad World® Forums

gfx export and compare model issue

First one is definitely a bug. Any closing ‘Export to graphics’ file dialog, adds additional backslash to file path, after device letter.
For example if I have D:\some_pict.jpg, after closing and reopening the dialog, it turns into D:\some_pict. Action done multiple times will result adding a lot of slashes. Additionally, while path contains incorrect number of backslashes, opening file requester doesn’t work at all.
I believe this bug appeared in TDM 4.

Second think is related to comparing db with model. Even if I deselected checking character set for entities, I got all entities listed for charset difference. I noticed this issue comparing mysql database with a model. I think I reported this issue a year ago but don’t remember the answer :wink:

best regards

Hi Michal,

for the bug in Export to Graphic File, I created change request CR 88446. Thanks a lot for this!

Concerning charset comparing, we didn’t manage to reproduce the issue. We tried it with mysql dbs and models and when we unchecked the charset check in Select Object Types | Detailed Settings, it never displayed the difference.
Any details on this to have us reproduce the issue? :slight_smile:

And concerning the issue you reported a year ago. I found the change request- CR 69068. It’s still in progress. We aimed at having it included in TDM 4.0, but other more urgent CRs had to be addressed first and the issue repairing impacts the Postrge implementation a lot and therefore requires a lot of testing… and therefore we didn’t make it in version 4. It’s planned for next full release. I will inform you here.

Regards,
Lukas

Hi Michal,

this change request 88446 has been already fixed and should be implemented in next full release at the end of August.
The issue appeard only when change the export path to another local drive and only when saving to the root of the local drive.

Regards,
Lukas