Toad World® Forums

High CPU Every Minute

I'm using Toad for Oracle 13.1.0.78
Every 60 seconds, Toad jumps from 0% CPU to 16% CPU and my keystrokes or mouse movements stall.
I usually start Toad with a session browser, schema browser and editor window. The problem starts after I run a query in the editor.
I then close all the windows, but Toad continues to use high CPU every 60 seconds.
It is pretty annoying.

One thing that might help the next time you launch Toad is to turn on SQL Spooling (From the main menu, choose Database|Spool SQL) and then choose to have Toad either spool to itself or to a file. This facility documents the SQL statements that it sends to the database on your behalf. If the spikes in CPU are caused by activity to the database, I'm hopeful you'll be able to identify which SQL commands might be causing Toad to spike.

Would be interested to hear our Dev Team's thoughts on possible causes.

Do you see the same problem, if you don't have Session Browser open? Session Browser has a refresh setting. If that's checked, then it'll refresh every x seconds (based on what your Refresh rate is set to).
image

It was not the debug.sql file. That does not contain anything I didn’t do on purpose.

The high CPU period does correspond to the writing of other files in the user file folder, namely these shown. The 1:44pm files are being updated every minute.

Henry
Clark

Senior Database Developer

Your ToadActions.dat file is large. Close Toad, rename the file, start Toad and see if the problem persists as a test. Afterwards close Toad and restore the file so that you don't lose any of your actions. Toad auto-saves settings every 1 minute.

If ToadActions.dat is the culprit, open Utilities > Automation Designer, select the Action Recall node on the left, and see how many saved actions you have on the right side. If you have a ton you can safely delete them. Actions there are most recently used actions intended for later recall. If you're not using that you can nuke them.

I did turn refresh off while trying to figure out the problem.

This was the issue, the size of the file written every minute.
I don't use automation designer so I deleted everything and the next actions file was 120 kb.
Problem solved, thank you very much.

Since you're not using actions you can change the setting so that it doesn't get out of control again. Set this option to something small.

image

Got it Thanks again.