Toad World® Forums

How can I connect to Salesforce via TLS 1.1 or 1.2

Hello,

Salesforce has disabled TLS 1.0 for all Sandboxes and will be disabling it for Production environments early next year. How do I connect to my SF Sandbox via TLS 1.1 or 1.2?

Thank you

This is handled internally, so you do not need to change anything about how you connect to the server. Furthermore, we negotiate the highest available TLS version supported by the server, up to TLS 1.2, so your connection will continue to work after the change.

Hi Ryan,

Thanks for the quick reply. Do you have any idea why I would be getting this error when trying to connect to a Salesforce sandbox environment? This only started happening when TLS 1.0 was retired in my Sandbox.

And I also get this error when I try double click an already created SF Sandbox connection:

This issue was resolved in TDP 4.0. For now, try doing a create like on that connection and use that new connection. Entering a different name for the copied over connection (the box for that is on the bottom) would help too.

Just saw the second post. Again, I would try recreating the connection with a slightly different name. Do let me know what the results are.

This isn’t working for me in 3.7 even after creating a new connection to our QA environment - still getting the UNSUPPORTED_CLIENT: TLS 1.0 has been disabled in this organizati’ from HUB error message.

Is this fixed/worth attempting in 3.8?

Toad Data Point 4.0 was released today. Try that version as Ryan says it is fixed there.

I’m using Toad Data Point 4.0 and am trying to create a new connection to a Salesforce sandbox. I have the url, username, password, and security key. However, in 4.0, when I select “Create a New Connection” and select Salesforce, the three tabs for security token sign-on, Single Sign On using your corporate network, and Single Sign On (SSO) don’t appear, so I can’t create a new connection.

In fact, you get an error message, “There was a connect error. Check that the username and password are correct, that you have registered this user using the registration tab, and that the registered user has not been disabled.”

This indicates to me that when the user tries to create a new connection to Salesforce, TDP 4.0 actually tries to connect without the url (!), username, password, and security key, and since it is not displaying the normal tabs for entering those key connection fields, one can’t create a new Salesforce connection in 4.0.

Hi Eric - Did you c hange the URL to your custom URL right when you bring up the ‘create new connection’ screen? (see attached screenshot)Salesforce connection screen.jpeg

Hi, Julie,

What I’m saying is, that in 4.0, those tabs do not come up. There is no where to enter the login information when you select “Create a New Connection” for Salesforce.

Can you start local storage? I suspect that the issue is there. Please open a support case and we will assist.

Hi, Debbie,

I tried to start Local Storage, and it does not open. I have started a service request ticket.