Toad World® Forums

Connect with SalesForce

Hi,
I am trying to create the connection with salesforce, but I have the error 4206. The logon Id, password and secutiy token are OK. Please advise what is needed to fix this issue. Thanks a lot.

Please see if this post is of any help for you: http://tda.inside.quest.com/thread.jspa?threadID=35723

Thanks,

Igor.

Please go to your desktop shortcut and add this to the comman line. " /log=all"

Then start TDA and try to connect to Sales force. When you get the error take a sreenshot of your logon and the error.

Then click on the support bundle. It will gather up some log files. Post the toad.log, hubproxy.log and mysqld.log.

Debbie

HI Debbie, nice to be in contact with you again.
I tried to add the suggested text at the end of the target but I got the error pointing the target box is not valid… The attached files show the error when establishing the connection and the bundle.
errors.doc (241 KB)

HI Debbie, nice to be in contact with you again.
I tried to add the suggested text at the end of the target but I got the error pointing the target box is not valid… The attached files show the error when establishing the connection and the bundle.
ToadSupportBundleToad for Data Analysts.zip (342 KB)

Thanks for the files. I will forward to developers that handle this area.

The message does complain about the logid. Can you check the simple stuff?

  1. Logon to Salesforce on their website and validate your logid.
  2. While on their website generate a new security token. Check when copying and pasting that the token is complete and doesn’t have extra spaces, etc.

I will let you know what the developers say from reading the files.

Debbie

Here is what Dev had to say:

“The first part of the security token doesn’t look randomenough. The security token for the testaccount we have is 24 characters, this one is about 33. Perhaps they’re prepending the password onthe security key?”

The security token should only be the token and not the password and token togeher. Can you check?

Debbie

Hi Debbie,
I have verified The logon ID and password I am using is a valid combination. On the other hand, the token I received has 25 characters; but when I was creating the salesforce connection in TDA, I entered the password and the security token in the token field. Anyway, I tried this morning to logon by entering only the secutity token in the security token field. The error is attached as well as another bundle.
error.doc (97.5 KB)

Hi Debbie,
I have verified The logon ID and password I am using is a valid combination. On the other hand, the token I received has 25 characters; but when I was creating the salesforce connection in TDA, I entered the password and the security token in the token field. Anyway, I tried this morning to logon by entering only the secutity token in the security token field. The error is attached as well as another bundle.
ToadSupportBundleToad for Data Analysts.zip (185 KB)

I sent to the developers.
Debbie

Do you need to use a proxy? If so please go to the options and enter the proxy data. See screenshot.
Debbie

Hi,

The problem was with proxie info. I removed the info from the table. and I proceeded to establish the connetion by entering in the secutity token only the token. Now I connected with SalesForce. Excellent. Thanks Debbie.

Yay!