Toad World® Forums

SalesForce Connection

#1

Trying to set up a SalesForce Connection in TDP 5.0 (trial) and the URL and authentication sections are disabled. Also will I be able to connect if we're using SalesForce Professional edition or is Enterprise edition required?

#2

Pro is all you need. Can you double click on Local Storage connection and see if you can start local storage. This is needed before the SalesForce connection can work.

#3

I think I was able to start Local Storage. After that I tried to create a SalesForce connection again but the URL and Authentication is still grayed out (disabled).
Is there any documentation on how to set up the SalesForce connection?

#4

After testing this a little more, I'm able to successfully connect to Local Storage. Then, when I try to add the SalesForce connection, I'm seeing 2 windows: "Need More Information to Connect" and "Create New Connection". If I click Connect on the "need more info" window nothing happens.

#5

Can someone please respond on the SalesForce connectivity issue I'm having?

#6

The connect info area needs to turn white and you need to select your type of authentication and credentials. Is https://login.salesforce.com the correct salesforce location for you? We use this by default for test connections. is this the correct URL for you instance? Put this into a regular browser. Can you connect there?

Also, if you wait a bit do you eventually get the connect info area to allow you to edit?

The developers for this area will be back on Monday. I will have them look at this post then. Please provide the details.

#7

https://login.salesforce.com
is correct. I tried waiting several minutes but the connect info area doesn’t turn white.

#8

Please help to check some points:
1.Does it only happen to Saleforce? Please help to check other type of connections like Generic OData, Oracle BI Enterprise.
2.Relaunch TDP with "Run As Administrator", try Saleforce connection again.
3.Check some processes in task manager: guardian.exe, hubproxy.exe, mysqld.exe.
4.Please generate a support bundle and send it to me to help analyze this issue.
Before generate support bundle, make a setting as the following:
1.Close TDP and right click TDP shortcut -> Properties -> Shortcut tab -> Target, append /log=all after the origin string, e.g. "C:\Program Files\Quest Software\Toad Data Point 5.0\toad.exe" /log=all


2. Repreduce this issue.
3. Help -> Support Bundle
Image%204
Image%205
4. Send the support bundle to me :cjay.zhang@quest.com

Thanks.

#9

I’m seeing the same issue with Generic OData and Oracle BI Enterprise

Still having the SalesForce issue when I run TDP as Administrator

I see the processes guardian.exe, hubproxy.exe and mysqld.exe all running in Task Manager

Just sent the support bundle.

#10

It was found that if you install with the option to not save passwords it will cause this issue. We have ticket QAT-14762 to fix this. For now please chose installer option to save passwords.
no%20passwords