Toad World® Forums

How do I configure Toad Data Point to default which database to be active on startup? "Connect on startup" property doesn't work.


#1

I have 3 database connections (in addition to the Local Storage Connection) setup in my Toad Data Point 3.6.1.3294 and only one of those has the “Connect on startup” box checked in the connection properties. However every time I startup TDP it seems to randomly pick which database connection it wants to be active initially by default, regardless of which database connection I was last using before closing TDP. Besides this being a minor nuisance, I am concerned that this behavior might be responsible for other issues I’m seeing with automated scheduled tasks trying to run in the background on my computer when Data Point is not running, or when I am logged off of the computer.

Any thoughts?

Thanks!

  • Jonathan

#2

Sounds like voodoo…Can you check an option for me? Go to Tools | Options | Desktop configurations. What options are checked. Change them to look like below. These options are for remembering where you last were when you shutdown and reopening those connections and windows. There was an earlier release where a few of these options were on by default and it confused a lot of us. Set as below and it should be fine.


#3

Yes, there were two other options checked by default (Open connections & Open documents) so hopefully unchecking them fixes it. The problem seemed intermittent, so it may take a while for me to feel assured the problem is permanently solved, but I’m guessing it is solved. Thanks!