Toad World® Forums

Data Grid Sizing


#1

Good Morning;

I’ll bet I’m missing something obvious. Toad 10.6.0.42.

Issue, when I run a query all columns appear compressed and I get to mess around
with resizing in order to see both data and headers.

I’ve the following settings:

Data Grids -> Visual -> Column Sizing -> Size to Data – selected

Data Grids -> Visual -> Column Sizing -> Min column size: 30

I’ve even restarted Toad after saving the settings and the columns are
still compressed.

For example, I have one field called Status, value “Approved”. What
shows up in the data grid is:

Header: STAT…

Data: APPR

The compression appears to be consistent across all character fields, only the
first four values are shown.

Question: What setting(s) do I need to change in order to see the full header
plus the full data?

It’s almost like the default column width is a fixed size and then you get
to resize it differently after that. Just eyeballing the 10 columns that show up
on the screen appear to be a consistent width in all the columns.

Thanks!

Roger A. Simoneau
Alberta Blue Cross
(780)498-8837


#2

Morning Roger,

I’ll bet I’m missing something obvious. Toad 10.6.0.42.
Me too, in a Windows XP VM on my Linux laptop!
I can’t use this release of Toad at work, but it’s my laptop, so I can
do what I like!

I’ve the following settings:

Data Grids -> Visual -> Column Sizing -> Size to Data - selected
Data Grids -> Visual -> Column Sizing -> Min column size: 30

I’ve got size to header ticked and for a select * from dba_objects, it
shows the headers correctly. Wider data I can live with.

Using your settings, the same select gives me wider columns (min 30)
however, this only happens on new grids - I had to open a new SQL window
to see the changes.

I’ve even restarted Toad after saving the settings and the
columns are still compressed.
I only had to open a new grid, but a restart should have made the
changes stick - unless your options are somehow not being saved?

Cheers,
Norm. [TeamT]

Information in this message may be confidential and may be legally privileged. If you have received this message by mistake, please notify the sender immediately, delete it and do not copy it to anyone else.

We have checked this email and its attachments for viruses. But you should still check any attachment before opening it.
We may have to make this message and any reply to it public if asked to under the Freedom of Information Act, Data Protection Act or for litigation. Email messages and attachments sent to or from any Environment Agency address may also be accessed by someone other than the sender or recipient, for business purposes.

If we have sent you information and you wish to use it please read our terms and conditions which you can get by calling us on 08708 506 506. Find out more about the Environment Agency at www.environment-agency.gov.uk


#3

unless your options are somehow not being saved?

They’re definitely being saved. I’ve confirmed across sessions
including on a clean start of Windows XP this morning. Additionally, they are
having an effect. I altered the selection to the header and those display
properly now. However, the minimum width of 30 still seems to be getting
ignored.

If it helps I started with an almost clean installation. The tech guy ran into
an issue with the first attempt to install. He initially proceeded to remove the
previous version I had installed (9.7.1.1). His second attempt installed Toad
but I wonder if something else might have gone wrong that wasn’t noticed.

Additionally I deliberately moved the personal files for the previous version so
when Toad provided the window to import previous settings, nothing was
available. So – in theory – I should have had a completely clean
installation with nothing to corrupt the settings files.

For the moment, I can live with the data grid showing full headings only. With
this, I won’t have to resize anywhere near as often as I was :slight_smile:

Roger S.


#4

However, the minimum width of 30 still seems to be getting ignored.

Be aware what the units are for that number. I don’t know what they are,
but they’re pretty tiny. I use a minimum width of 35 so that I always see
at least two letters of the column name. Try bumping your minimum up to 200 or
so; then you’ll see it taking effect. Then bring it down to whatever you
want.

Nate Schroeder

US Seed & Trait Commercial IT - Data Management Team

Monsanto Company

800 N. Lindbergh Blvd. LC4D - Saint Louis, MO - 63167

314-694-2592

This e-mail message may contain privileged and/or confidential information, and
is intended to be received only by persons entitled
to receive such information. If you have received this e-mail in error, please
notify the sender immediately. Please delete it and
all attachments from any servers, hard drives or any other media. Other use of
this e-mail by you is strictly prohibited.

All e-mails and attachments sent and received are subject to monitoring, reading
and archival by Monsanto, including its
subsidiaries. The recipient of this e-mail is solely responsible for checking
for the presence of “Viruses” or other “Malware”.
Monsanto, along with its subsidiaries, accepts no liability for any damage
caused by any such code transmitted by or accompanying
this e-mail or any attachment.

The information contained in this email may be subject to the export control
laws and regulations of the United States, potentially
including but not limited to the Export Administration Regulations (EAR) and
sanctions regulations issued by the U.S. Department of
Treasury, Office of Foreign Asset Controls (OFAC). As a recipient of this
information you are obligated to comply with all
applicable U.S. export laws and regulations.


#5

Be aware what the units are for that number.

I don’t know what they are, but they’re pretty tiny.

Heh, I guess the expectation of “30 characters” was out to lunch :wink:

However, you are correct. Upon testing it, whatever the unit is on my particular
set up, it’s really, really tiny.

Additionally, it’s not so much the minimum size that was causing the
effect I saw but the maximum. I’ve set all the fonts I could find
consistently to courier new, regular, 10 point.

With that setting and a max size of 152 I can see the full 19 character varchar2
field value. If I change the setting to 151, the truncation on that field
begins. I think I’ll call the unit affecting my setting an octavian :wink:

Roger S.


#6

Just to get my 2 cents in. I have specified a smaller font for my headings than
my data. Going under the assumption it is better to read the data correctly. So
if I size my columns to the data I don’t often have to drag the columns
larger to see the column name.


#7

I’ve wondered forever if this works for anyone. I have the size column to data selected, yet it doesn’t seem to have any effect on the grids at all as I still have to double click on the grid header line to size the columns.

One place it is particularly annoying is in the table columns tab in the schema browser. It seems that the same grid tech is used for those grids as well, but the columns are never sized right.


#8

I have the size column to data selected,

yet it doesn’t seem to have any effect on the grids

What I found affected the sizing the most was the restriction on the maximum
size. First, it should be understood that the sizing is not based on characters
– thanks to the one that pointed this out to me.

In my case, based on some observational testing, it takes 8 points for a
character (based on courier new, 10 point font). As a result, my original max of
30 was really 30/8 = 3 characters displayed. I have my minimum set to 1 and
maximum set to 152. This now displays the first 19 characters.

Options -> Data Grids -> Visual -> Column Sizing section.

As I have the null value set to {NULL}, I’m pretty sure the minimum sizing
is pretty much being completely ignored which is fine. If you alter the maximum
column size setting, I’m sure the results will improve.

Roger S.


#9

Well, my max was 5000 (not sure if that was the default, but I’ve never changed it) and my min was 20. My problem is that on the columns grid, the columns are sized too large and sometimes sized too small. Sometimes they are way larger than the data value and you need to shrink them just to see more columns; sometimes they are too small and for example, the datatype is wrapped causing the grid to be longer than it needs to be.

Usually for regular table data grids, the columns are sized too small and i need to widen them to see all the data, even though i have the ‘size to data’ checked. I’m quite sure i’m not hitting my max width of 5k when i have to widen a column that is only varchar 20 (for example).

It seems especially bad w/ dates, usually not showing the last two characters.


#10

Here’s another idea that may explain what you’re seeing. I also use
“size to data” as my default setting. When Toad pulls data in from a
table and puts it in a grid, it sizes the columns to the data in the first few
rows. (I don’t know if it uses the first 500, or the first screenful, or
what.) If you then scroll down in the data set, you may come to rows where
certain columns have wider data. Toad will not dynamically resize the columns as
you scroll; once they’re set they’re set, unless you manually change
them. I frequently lose the last bit of dates this way, if the first few rows
all have one-digit months and then further down I get to October data, which
takes one more character of width in my date format.

Nate Schroeder

US Seed & Trait Commercial IT - Data Management Team

Monsanto Company

800 N. Lindbergh Blvd. LC4D - Saint Louis, MO - 63167

314-694-2592


#11

Thanks, but that’s still not the issue. The columns that aren’t sized correctly start right off in row 1.


#12

sssss.png

click on the ND button. It will fix the issue