Toad World® Forums

How do I get Data Point to execute a dml file in SQL Editor

Using Toad Data Point 3.2.0.921, I open a file with a “sql” extension in the SQL Editor and the “Execute SQL” option in the “Edit” menu is enabled as expected and I can execture that SQL script. Good so far.

However, when I open a file with a “dml” extension in the SQL Editor, the “Execute SQL” option in the “Edit” menu is disabled and I cannot execute the script even though it contains SQL statements.

I have added “dml” as an extension in the Options/Environment/Extensions window but I still cannot execute scripts with “dml” file extensions.

How do I get Toad Data Point to recognize a file with a “dml” extension as a file containing SQL statements that can be executed from the SQL Editor?

Thanks

The DML files are associated with Depiction Element Definition and they contain elements that Toad cannot recognize as a valid SQL.
So the simplest way is to copy and paste the SQL(s) or leave the SQL(s) and delete (or comment out) the rest.
If this does not help could you please attach a dml file as an example so we can look at it.

Our files with dml extensions contain only SQL statements.

For example,

delete from zipcode;
commit;

delete from address;
commit;

etc.

Is there a way to get Toad Data Point to recognize this file as a simple list of SQL statements that can be executed?

We are able to execute these *.dml files in plain old Toad for Oracle

I just tried to do the same in Toad Data Point and discovered the problem

We could simply rename our *.dml files to *.sql but I wanted to check if there was some other way

We were able to reproduce the issue with TDP 3.2. But TDP 3.3 beta does not have the issue.

Could you try the 3.3 beta? You can download it from http://tda.inside.quest.com/beta.jspa

I just opened the dml file with Toad Data Point 3.3.0.1404 Beta Version
but the execute SQL button is still not enabled in the SQL Editor

  • see attached image

I am running the 64 bit version of the beta on 64 bit Windows 7 Enterprise - Service Pack 1

Message was edited by: Frank Calfo
toad.png

I see. Can you attached a dml file?

Thanks
Aleksey

I had to attach a file with dummy table names but the result is the same with this dml file - no execute sql button enabled
tce_purge_foo.dml (102 Bytes)

Hi Frank,

I looked more closely on the screenshot you provided and it looks like you don’t have a connection for the editor. Look at the connection dropdown box at the top toolbar. It’s empty. Please set the connection for the editor. Also you can check the connection if you place mouse on the editor’s tab. You should see the editor’s connection in tooltip.

Aleksey

DOH! that was it - once I actually established a db connection then the execute option was enabled in the SQL editor - thanks!