Toad World® Forums

How to access apps views - where current schema has synonyms

After installing TOAD 12.10 for Oracle I cannot view the data owned by apps views - I am using read only access which has synonyms for the views but they do not show the data

On previous TOAD (before installing 12.10) I could access data in these views from the same (non APPS schema)

Do I need to do something else before I can see this data?

There shouldn’t be any difference. How are you trying to access the data - Editor/Schema Browser/Both? Are you sure your using the same account and using the same connection type (eg. Normal/SysDBA/etc.)? Does running the query in SQL*Plus return the data using that same account?

I just created a read-only account on our local APPS db and it works in 12.10 here. I ran the following in the editor and it returned the rows correctly…

select * from apps.hr_locations;

apps views
IMHO, some views may depend on some functions that may not be able to return results, so parent views, return wrong records.
In APPS, many views depends on session env settings (defined by apps session before) and if those settings are not setup you will get no records in view.

So, if you look in view definition of one problematic view you may see the reason
Hope this helps.
Damir

P.S.
This means that any Oracle tools (SQL*Plus as well) will return the same result.