Toad World® Forums

How to Arrange 600 tables automatically


#1

Hello ALL,

I am trying to create a data model based on Oracle (near 600 tables)) and the TDM created it but, the tables are coming on the top of the other. I did not see any differences using the ‘Autolayout’.
Is there a way to get a readable output using these amount of objects?

Thank you all,
Ed


#2

Hi Ed,

Some tips to modify the look of entities on the WS (probably you have large entities):

  1. Display level combo box on the toolbar - Select what you need to display in the entity box.
  2. Right-click the WS | Workspace Format | Entity tab, disable e.g. the Display Keys Graphically option.
  3. Select Settings | Options | Graphics | Autolayout area | enlarge the horizontal and vertical distance coefficient. Confirm OK and click the Autolayout icon on the toolbar again.

I hope this will help.

Other possibility is to divide the ERD - to create several workspaces and add groups of entities on each.
Flash movie on shortcuts of objects on workspaces:
http://modeling.inside.quest.com/entry.jspa?externalID=1666&categoryID=158

In any case, we plan to improve the autolayout functionality in some of the future TDM releases. CR # 54 040.

If you have any questions, please write me back. Thanks.

Regards,

Vladka + TDM Team


#3

Hi Vladka,

Although the tips are helpfull they did not help at all.
I have set up the horizontal and vertical distance coefficient up to the maximum value
and it still printing the tables one on the top of the other.

Thank you,
Ed


#4

Hi Ed,

Sorry to hear this. Could you please send us the model? We will check it out.
(Please send it to modeling@quest.com. Thanks.)
Also, please send us some screenshots of the problem.

You write you are printing the tables. Please write us what page format settings you have (screenshot of the Page Format dialog).
How about the Preview? Is the problem visible in preview?

Thanks for more details.

Regards,

Vladka + TDM Team


#5

Hi Vladka,
sorry but, I was not allowed to send it through.
Thank you for any help given.


#6

Hi Ed,

No screenshots either?

We’re sorry, we need more information to have an idea on how to simulate the problem. So far, we have failed to simulate it. Sorry.

Regards,

Vladka