Toad World® Forums

How to Improve TDM Graphical User Interface Performance?

Hello,

I have an Oracle physical modeled in TDM 7.1 on Windows 10 that has quite poor performance with the Graphical User Interface. "Every" mouse click event and window opening/closing has considerable lag. I've resorted to pretty much doing all manipulations through programming interface, which for the same actions performs much faster which leads me to conclude it is the graphical user interface that is slowing TDM down. I try to only use the user interface to layout the entities/relationships in the workspace(s). Are there any performance tuning tricks?

The model has the following statistics.

TXP File size: about 19KB
Entities: 332
Attributes: 3391
Relationships: 794 (88 of which are identifying)
Indexes: 1518
Keys: 478 (332 Primary Keys)
Tablespaces: 3
Views: 21
View Relationships: 26

I have about 20 workspaces. Many entities are not displayed on any workspace and some entites/relationships are shown on several workspaces.

I've turned off the auto complete feature of the All Items workspace (can't say this helped much if at all).

I've noticed performance goes down for updating entities that have many relationships, especially if those relationships are shown on Workspaces.

I have tested and repaired all model issues (missing back links, etc.).

The computer is a corporate computer that has a lot of security scanning / monitoring software, so the issue could very well be the other software installed and running on the machine; however, I cannot control that software. Looking to TDM to offer any advice. Thanks in advance.

Using TDM 7.1.0.216 On Windows 10 Enterprise Version 1809 OS build 17763.914, 16 GB RAM, Intel Core i5-6200 CPU @ 2.30 Ghz 2.40 GHz.

Hello Alex,
Your model is not so big to cause such issues. Are you able to create (or already have one) similarly big model and test if there will be same problem?

The recommendations are to

  • not have opened too many edit forms (messages are sent between those forms and this can cause slow down)
  • work on workspaces with less objects - or if you have more objects there don't zoom out too much - it will render all objects visible on the screen, rest is skipped in rendering
  • if you have Grid turned on - try to turn it off

TDM-grid-hide

  • also, you've mentioned that you are using scripting interface - that brings me an idea that you have possibly opened Package Explorer - this explorer is very resource hungry, try to close it.

Also in Options -> Expert Mode of Toad Data Modeler, you can turn on benchmark feature, that will track some things. One of those things is also form opening. (you will turn on Expert mode in General tab of the Options).

Tracked time is then logged to Message Explorer (at the bottom of the screen by default).

Have a nice day,
Michal

Thank you for the reply and ideas.

Package Explorer was/is not open.
Show grid was/is not on.

Roughly speaking, how many objects/aliases should I try to stay under per workspace?

Does an open workspace that is not active cause issues? (Limiting the number of open workspaces hasn't seemed to have much impact.)

It takes about 3 seconds to open a workspace window and about a full 2 seconds to switch between workspace windows. Is that normal?

I experience lag when switching between the scripting window and the model window (even if there are no edit forms open). It takes about 2 seconds to go from scripting window to model window (and screen objects flash and appear to (re)render) and about 1-2 seconds to go from the model window to the scripting window.

Another common lag issue is in the Entity Form | Attribute tab and then pressing F2 or double-clicking to edit the attribute's Comment. Sometimes the comment becomes editable instantaneously, but other times it can take upwards of 15 seconds.

The benchmarking is showing 1700 miliseconds (2000 for an entity with a lot of relationships) to open an entity form, 1300-1800 mliseconds to open a relationship form, and 1000 miliseconds to open an index form. Though closing the form (even if there are no changes to apply seems to take longer, and is not tracked by benchmarking). It took about 3 seconds to change the relationship's Parent Key. Are these normal times?

Saving the model takes about 10-18 seconds and the screen flashes a couple of times (saving to a local drive). Is that normal for a model of this size?

It takes about 30 minutes to generate the full RTF report of the model. (I am willing to live with this, but mention it only in case it is a clue as to what else may be going on.)

The machine currently has both TDM 6.5.4.14 and TDM 7.1.0.216 installed. Is there any chance that having both installed simultaneously could be causing the issue?

Will uninstalling 6.5.4.14 have negative impact on the TDM 7.1.0.216 installation?

Thank you.

38161 milliseconds to open the model.

It took about 3 seconds to change the relationship's Parent Key (on a completely brand new child entity).

After having worked on the actual model now (whose entity's are full of attributes, keys, indicies, and relations) with benchmarking turned "on", some entities and attribute form windows are taking 4000-5000 miliseconds to open. These entities have about 20 attributes, 3 keys, 10-15 indices, 10-15 relations). Is this normal benchmarking time for such entities?

Those are really high values, that doesn't occured before (even customers didn't reported it). Is it possible for you to share the problematic model for us to let us perform some internal testing?
If you are able to provide the model, please send it to michal.vasut@quest.com - the model will be treated as confidential.

Thanks, Michal

Hello again Alex,

We've tested your model (that you've sent via mail) and there are some points from that research:

First thing we've noticed is that your model is using Naming convetions (stored in separate file) that wasn't included with the model, so our measurements aren't so precise as it could be.

We've tested on 2 separate machines to make better picture

Task Your time Machine 1 Machine 2 Note
RTF report > 30 min < 10min < 10 min
Model Test long time 53 s 62s OK for model of this size
Open Model cca 1 min 10s 9s OK for model of this size
Identifying -> Nonidentifying relation ? 10s 4s There is problem, that needs to be addressed
Save Model long time 7s OK for model of this size
Change attribute comment from Entity form via F2 long time instant instant

So based on our measurents and the size of the model, the times aren't so terrible. There is an issue mentioned in the table, that we will look into, all in all it's quiet OK for model of this size and complexity.

I can compare only times that you've mentioned:

  • RTF report - as you can see our times are 3 times lower than yours
  • Open model - there is even bigger gap

You've mentioned that your machine is equiped and frequently checked by some security solution (thread protection) and that can cause some slow down.

Best regards, Michal

Thank you to you and your team for reviewing.

I am not using a naming convention file. I receive a warning message every time I open the application saying

File "trigger_convention.txn" with naming convention definition linked to model "[REDACTED]" has not been found.

The installation folder in Documents only contains the default CSV.
C:\Users[USER_NAME]\Documents\Toad Data Modeler\Standard Installation\Naming Conventions\

The above folder is empty other than the "CSV" folder. It does not contain "trigger_convention.txn".

Tools | Naming Convention | Manage ... shows no items.

How do i unlink this file from the model?

This seems like a bug and the Naming Convention cannot be unlinked in any convenient way.

There are 2 workarounds (very messy solutions)

Shorter, but more technical

Warning: Changing the file this way is at your own risk and it may corrupt the file if not done properly.

  1. The model file is basically XML file, so open it in some XML editor (better) or text editor (worse)
  2. Find node PERModelOR12R2 > NamingConvFile and delete its content
  3. Save the file

GUI way: Assign new Naming Convention

  1. Tools > Naming Conventions > Settings...
  2. Popup will appear that there is no Naming Convention etc. ... click Yes to confirm it
  3. Dialog for entering Naming Convention appears, so enter something (doesn't really matter what)
  4. Naming Convention Properties will appear, so close it
  5. Open Naming Conventions list - Tools > Naming Conventions > Manage...
  6. Delete the Naming convention and save model

Thank you. That worked.

Also, how long does it take your team to open the entity form "DeductionDIm" with benchmarking on? For me it's like 2400 milliseconds.

Thank you for these information.

DeductionDim entitity form open time: 678 ms

Hi,

I am experiencing a very similar problem after upgrade from Windows 7 to W10 on the same laptop. W7 response times were "instant". In W10 it is taking 5-6 seconds to open entity or attribute for an edit.

I have upgraded TDM from 7.1 to 7.2 last week as per Quest support chat suggestion without noticeable performance improvement. The issue does not appear to be related to model size. The response time is consistently slow for models with 20 and 110 entities.

I have followed instructions provided in this thread, but no improvement. Any additional suggestions welcome.

Thank you